Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Newer
Older
100644 31 lines (25 sloc) 1.196 kb
4d3744f @thibaudgg Initial commit
thibaudgg authored
1 # -*- encoding: utf-8 -*-
03aa0b0 @mislav gemspec: avoid adding the "lib/" directory to load path
mislav authored
2 Kernel.load File.expand_path('../lib/guard/version.rb', __FILE__)
4d3744f @thibaudgg Initial commit
thibaudgg authored
3
4 Gem::Specification.new do |s|
5 s.name = 'guard'
6 s.version = Guard::VERSION
7 s.platform = Gem::Platform::RUBY
8 s.authors = ['Thibaud Guillaume-Gentil']
9 s.email = ['thibaud@thibaud.me']
29f671b @mislav change gem "homepage" property to the GitHub project
mislav authored
10 s.homepage = 'https://github.com/guard/guard'
d5a5fa1 @mislav fix grammar in gem summary & description
mislav authored
11 s.summary = 'Guard keeps an eye on your file modifications'
12 s.description = 'Guard is a command line tool to easily handle events on file system modifications.'
d37502d @thibaudgg Updated dev gems
thibaudgg authored
13
1b62072 @thibaudgg Cleaned Guardfile
thibaudgg authored
14 s.required_rubygems_version = '>= 1.3.6'
4d3744f @thibaudgg Initial commit
thibaudgg authored
15 s.rubyforge_project = 'guard'
d37502d @thibaudgg Updated dev gems
thibaudgg authored
16
fc3e179 @netzpirat Add yard and kramdown to development dependencies.
netzpirat authored
17 s.add_dependency 'thor', '~> 0.14.6'
8669b49 @joshbuddy eliminate per-platform deps
joshbuddy authored
18 s.add_dependency 'ffi', '>= 0.5.0'
fc3e179 @netzpirat Add yard and kramdown to development dependencies.
netzpirat authored
19
ec2de27 @thibaudgg Removed bundler dev dep version (Travis is now using 1.1.pre.4)
thibaudgg authored
20 s.add_development_dependency 'bundler'
0043c86 @netzpirat Initial readline support.
netzpirat authored
21 s.add_development_dependency 'rspec', '~> 2.7.0'
8844b52 @thibaudgg Update dev gem dependency
thibaudgg authored
22 s.add_development_dependency 'guard-rspec', '~> 0.5.0'
673a340 @netzpirat Yard 0.7.3 is required for GitHub code blocks. Add pry.
netzpirat authored
23 s.add_development_dependency 'yard', '~> 0.7.3'
09ce096 @netzpirat Use redcarpet as markdown engine. Welcome back, colors.
netzpirat authored
24 s.add_development_dependency 'redcarpet', '~> 1.17.2'
673a340 @netzpirat Yard 0.7.3 is required for GitHub code blocks. Add pry.
netzpirat authored
25 s.add_development_dependency 'pry', '~> 0.9.6.2'
d37502d @thibaudgg Updated dev gems
thibaudgg authored
26
f56db54 @rymai Don't gzip the man page for now.
rymai authored
27 s.files = Dir.glob('{bin,images,lib}/**/*') + %w[CHANGELOG.md LICENSE man/guard.1 man/guard.1.html README.md]
4d3744f @thibaudgg Initial commit
thibaudgg authored
28 s.executable = 'guard'
29 s.require_path = 'lib'
34a77de @netzpirat Use the latest guard-rspec for development.
netzpirat authored
30 end
Something went wrong with that request. Please try again.