Permalink
Browse files

Properly close rb-fsevent pipe after killed it

Closes #5.
  • Loading branch information...
1 parent 7bae189 commit 5d0ec698defe72b83881bdbaf5e7350da1055ec9 @thibaudgg thibaudgg committed Oct 25, 2010
Showing with 9 additions and 3 deletions.
  1. +6 −0 CHANGELOG.rdoc
  2. +1 −1 Gemfile
  3. +2 −2 lib/guard/listeners/darwin.rb
View
@@ -2,6 +2,12 @@
Bugs fixes:
+- Avoid creating new copy of fsevent_watch every time a file is changed. (issue #5)
+
+== 0.2.1 (Oct 24, 2010)
+
+Bugs fixes:
+
- Fixes for Linux support
== 0.2.0 (Oct 21, 2010)
View
@@ -5,7 +5,7 @@ gemspec
require 'rbconfig'
if Config::CONFIG['target_os'] =~ /darwin/i
- gem 'rb-fsevent', '>= 0.3.3'
+ gem 'rb-fsevent', '>= 0.3.4'
gem 'growl', '~> 1.0.3'
end
if Config::CONFIG['target_os'] =~ /linux/i
@@ -25,8 +25,8 @@ def stop
def self.usable?
require 'rb-fsevent'
- if !defined?(FSEvent::VERSION) || Gem::Version.new(FSEvent::VERSION) < Gem::Version.new('0.3.3')
- UI.info "Please update rb-fsevent (>= 0.3.3)"
+ if !defined?(FSEvent::VERSION) || Gem::Version.new(FSEvent::VERSION) < Gem::Version.new('0.3.4')
+ UI.info "Please update rb-fsevent (>= 0.3.4)"
false
else
true

0 comments on commit 5d0ec69

Please sign in to comment.