Permalink
Commits on May 3, 2016
  1. avoid unkillable thread problem on JRuby

    e2 committed May 3, 2016
    You can't kill a thread that is doing a sysread, so we just send a kill
    to those threads, and then we ignore them.
    
    The allows at least the Travis JRuby tests to run without hanging.
  2. activate JRuby-9.0.5.0 on Travis

    e2 committed May 3, 2016
Commits on Apr 30, 2016
  1. Release 3.1.2

    e2 committed Apr 30, 2016
  2. Merge pull request #383 from guard/fix_state_transition

    e2 committed Apr 30, 2016
    allow stopping when not fully initialized
  3. add TODO

    e2 committed Apr 30, 2016
  4. remove unused spec code

    e2 committed Apr 30, 2016
  5. Merge pull request #384 from guard/workaround_rubygems_spec_bug

    e2 committed Apr 30, 2016
    fix gemspec duplicate dependency validation error
  6. avoid gemspec "duplicate dependency" validation error

    e2 committed Apr 30, 2016
Commits on Apr 27, 2016
  1. Merge pull request #378 from guard/check_ruby_on_startup

    e2 committed Apr 27, 2016
    warn users if their Ruby is outdated or insecure [fixes #375]
  2. Merge pull request #379 from jvanbaarsen/make-rubocop-pass

    e2 committed Apr 27, 2016
    Make rubocop pass on the .gemspec file
  3. Merge pull request #380 from jvanbaarsen/remove-rubocop-todo

    e2 committed Apr 27, 2016
    Remove .rubocop_todo.yml
  4. Remove .rubocop_todo.yml

    jvanbaarsen committed Apr 27, 2016
    All the items that are listed in the rubocop_todo.yml are already fixed, making
    this file obsolete. Let's remove it!
    
    Signed-off-by: Jeroen van Baarsen <jeroenvanbaarsen@gmail.com>
  5. Make rubocop pass on the .gemspec file

    jvanbaarsen committed Apr 27, 2016
    Rubocop expects a single quote, and was throwing a warning on this line.
    
    Signed-off-by: Jeroen van Baarsen <jeroenvanbaarsen@gmail.com>
  6. check Ruby version on startup

    e2 committed Apr 26, 2016
Commits on Apr 26, 2016
  1. Merge pull request #377 from guard/use_ruby_dep_gem

    e2 committed Apr 26, 2016
    use ruby_dep for gemspec Ruby version constraint
  2. use OSX 10.10 on travis for precompiled Ruby 2.2.4

    e2 committed Apr 26, 2016
  3. bump Ruby to 2.2.4 (CVE-2015-7551)

    e2 committed Apr 26, 2016
  4. make sure ruby_dep is preinstalled

    e2 committed Apr 26, 2016
  5. use ruby_dep for gemspec Ruby version constraint

    e2 committed Apr 26, 2016
  6. Merge pull request #376 from guard/fix_version_constraints

    e2 committed Apr 26, 2016
    Use .travis.yml to set gem's dependency on Ruby
  7. point to .travis.yml for supported Ruby versions

    e2 committed Apr 26, 2016
Commits on Apr 25, 2016
Commits on Apr 23, 2016
  1. Release 3.1.1

    e2 committed Apr 23, 2016
  2. Merge pull request #373 from guard/add_missing_require

    e2 committed Apr 23, 2016
    explicity require forwardable
  3. explicity require forwardable

    e2 committed Apr 23, 2016
Commits on Apr 22, 2016
  1. Release 3.1.0

    e2 committed Apr 22, 2016
  2. add JRuby workaround for Travis

    e2 committed Apr 22, 2016
  3. Merge pull request #371 from guard/e2-mri2.2-rubocop_overhaul

    e2 committed Apr 22, 2016
    Update to Ruby 2.2 and RuboCop 0.38
  4. fix lots of RuboCop offenses

    e2 committed Apr 22, 2016
  5. switch to depending on Ruby 2.2+

    e2 committed Apr 22, 2016
  6. turn off Rails cops

    e2 committed Apr 22, 2016
  7. update RuboCop and HoundCi style

    e2 committed Apr 22, 2016