Permalink
Browse files

use bundler instead of jeweler for gem creation

  • Loading branch information...
1 parent 5a5ebef commit 6a662faa80146c6fec111a0058a4305ae079387e @netskin-ci netskin-ci committed Apr 22, 2011
Showing with 41 additions and 142 deletions.
  1. +0 −5 .document
  2. +4 −22 .gitignore
  3. +1 −0 spec/spec.opts → .rspec
  4. +4 −0 Gemfile
  5. +4 −46 Rakefile
  6. +0 −1 VERSION
  7. +3 −0 lib/sequel_rails3/version.rb
  8. +18 −55 sequel_rails3.gemspec
  9. +0 −7 spec/sequel_rails3_spec.rb
  10. +7 −6 spec/spec_helper.rb
View
@@ -1,5 +0,0 @@
-README.rdoc
-lib/**/*.rb
-bin/*
-features/**/*.feature
-LICENSE
View
@@ -1,22 +1,4 @@
-## MAC OS
-.DS_Store
-
-## TEXTMATE
-*.tmproj
-tmtags
-
-## EMACS
-*~
-\#*
-.\#*
-
-## VIM
-*.swp
-
-## PROJECT::GENERAL
-coverage
-rdoc
-pkg
-nbproject
-
-## PROJECT::SPECIFIC
+*.gem
+.bundle
+Gemfile.lock
+pkg/*
@@ -1 +1,2 @@
--color
+
View
@@ -0,0 +1,4 @@
+source "http://rubygems.org"
+
+# Specify your gem's dependencies in sequel_rails3.gemspec
+gemspec
View
@@ -1,48 +1,6 @@
-require 'rubygems'
-require 'rake'
-
-begin
- require 'jeweler'
- Jeweler::Tasks.new do |gem|
- gem.name = 'sequel_rails3'
- gem.authors = ['Corin Langosch']
- gem.date = Date.today.to_s
- gem.email = 'info@netskin.com'
- gem.homepage = 'http://github.com/gucki/sequel_rails3'
- gem.summary = 'Use sequel as a replacement for activerecord with rails 3'
- gem.description = 'Sequel plugin which provides geo distance-based filters and distance calculation functionality for model.'
- gem.add_dependency "rails", ">= 3.0.0"
- gem.add_dependency "sequel", ">= 3.0.0"
- gem.add_development_dependency "rspec", ">= 1.2.9"
- # gem is a Gem::Specification... see http://www.rubygems.org/read/chapter/20 for additional settings
- end
- Jeweler::GemcutterTasks.new
-rescue LoadError
- puts "Jeweler (or a dependency) not available. Install it with: gem install jeweler"
-end
-
-#require 'spec/rake/spectask'
-#Spec::Rake::SpecTask.new(:spec) do |spec|
-# spec.libs << 'lib' << 'spec'
-# spec.spec_files = FileList['spec/**/*_spec.rb']
-#end
-
-#Spec::Rake::SpecTask.new(:rcov) do |spec|
-# spec.libs << 'lib' << 'spec'
-# spec.pattern = 'spec/**/*_spec.rb'
-# spec.rcov = true
-#end
-
-task :spec => :check_dependencies
+require 'bundler'
+Bundler::GemHelper.install_tasks
+require 'rspec/core/rake_task'
+RSpec::Core::RakeTask.new('spec')
task :default => :spec
-
-require 'rake/rdoctask'
-Rake::RDocTask.new do |rdoc|
- version = File.exist?('VERSION') ? File.read('VERSION') : ""
-
- rdoc.rdoc_dir = 'rdoc'
- rdoc.title = "sequel_rails3 #{version}"
- rdoc.rdoc_files.include('README*')
- rdoc.rdoc_files.include('lib/**/*.rb')
-end
View
@@ -1 +0,0 @@
-0.0.4
@@ -0,0 +1,3 @@
+module SequelRails3
+ VERSION = "0.0.5"
+end
View
@@ -1,63 +1,26 @@
-# Generated by jeweler
-# DO NOT EDIT THIS FILE DIRECTLY
-# Instead, edit Jeweler::Tasks in Rakefile, and run 'rake gemspec'
# -*- encoding: utf-8 -*-
+$:.push File.expand_path("../lib", __FILE__)
+require "sequel_rails3/version"
Gem::Specification.new do |s|
- s.name = %q{sequel_rails3}
- s.version = "0.0.4"
+ s.name = "sequel_rails3"
+ s.version = SequelRails3::VERSION
+ s.platform = Gem::Platform::RUBY
+ s.authors = ["Corin Langosch"]
+ s.email = ["info@netskin.com"]
+ s.homepage = "http://github.com/gucki/sequel_rails3"
+ s.summary = %q{Use sequel as a replacement for activerecord with rails 3}
+ s.description = %q{This gem allows you to easily use sequel instead of activerecord with rails 3.x.x}
- s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
- s.authors = ["Corin Langosch"]
- s.date = %q{2011-03-15}
- s.description = %q{Sequel plugin which provides geo distance-based filters and distance calculation functionality for model.}
- s.email = %q{info@netskin.com}
- s.extra_rdoc_files = [
- "LICENSE",
- "README.rdoc"
- ]
- s.files = [
- ".document",
- "LICENSE",
- "README.rdoc",
- "Rakefile",
- "VERSION",
- "lib/sequel_rails3.rb",
- "lib/sequel_rails3/configuration.rb",
- "lib/sequel_rails3/logger.rb",
- "lib/sequel_rails3/railtie.rb",
- "lib/sequel_rails3/railties/controller_runtime.rb",
- "sequel_rails3.gemspec",
- "spec/sequel_rails3_spec.rb",
- "spec/spec.opts",
- "spec/spec_helper.rb"
- ]
- s.homepage = %q{http://github.com/gucki/sequel_rails3}
+ s.rubyforge_project = "sequel_rails3"
+
+ s.files = `git ls-files`.split("\n")
+ s.test_files = `git ls-files -- {test,spec,features}/*`.split("\n")
+ s.executables = `git ls-files -- bin/*`.split("\n").map{ |f| File.basename(f) }
s.require_paths = ["lib"]
- s.rubygems_version = %q{1.3.7}
- s.summary = %q{Use sequel as a replacement for activerecord with rails 3}
- s.test_files = [
- "spec/sequel_rails3_spec.rb",
- "spec/spec_helper.rb"
- ]
- if s.respond_to? :specification_version then
- current_version = Gem::Specification::CURRENT_SPECIFICATION_VERSION
- s.specification_version = 3
+ s.add_dependency "rails", "~>3.0.0"
- if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
- s.add_runtime_dependency(%q<rails>, [">= 3.0.0"])
- s.add_runtime_dependency(%q<sequel>, [">= 3.0.0"])
- s.add_development_dependency(%q<rspec>, [">= 1.2.9"])
- else
- s.add_dependency(%q<rails>, [">= 3.0.0"])
- s.add_dependency(%q<sequel>, [">= 3.0.0"])
- s.add_dependency(%q<rspec>, [">= 1.2.9"])
- end
- else
- s.add_dependency(%q<rails>, [">= 3.0.0"])
- s.add_dependency(%q<sequel>, [">= 3.0.0"])
- s.add_dependency(%q<rspec>, [">= 1.2.9"])
- end
+ s.add_development_dependency "rspec", "~>2.5.0"
+ s.add_development_dependency "rspec-rails", "~>2.5.0"
end
-
@@ -1,7 +0,0 @@
-require File.expand_path(File.dirname(__FILE__) + '/spec_helper')
-
-describe "SequelRails3" do
- it "fails" do
- fail "hey buddy, you should probably rename this file and start specing for real"
- end
-end
View
@@ -1,9 +1,10 @@
-$LOAD_PATH.unshift(File.dirname(__FILE__))
-$LOAD_PATH.unshift(File.join(File.dirname(__FILE__), '..', 'lib'))
+require 'rubygems'
+require 'bundler/setup'
+
+require 'rails'
+require 'active_support/all'
+
require 'sequel_rails3'
-require 'spec'
-require 'spec/autorun'
-Spec::Runner.configure do |config|
-
+RSpec.configure do |config|
end

0 comments on commit 6a662fa

Please sign in to comment.