error: "invalid date format specification" after install #27

Open
dvarrazzo opened this Issue Nov 29, 2011 · 1 comment

Comments

Projects
None yet
2 participants

Installed ruby for the first time on a pretty new machine. Ubuntu 11.10, ruby 1.8.7

Installation log:

$ pgxn install pgxn_utils
INFO: best version: pgxn_utils 0.1.3
INFO: saving /tmp/tmp19qGCo/pgxn_utils-0.1.3.zip
INFO: unpacking: /tmp/tmp19qGCo/pgxn_utils-0.1.3.zip
INFO: building extension
make: Nothing to be done for `all'.
INFO: installing extension
gem install --no-rdoc --no-ri -v=0.1.3 pgxn_utils

Fetching: json-1.5.4.gem (100%)
Building native extensions.  This could take a while...
Fetching: thor-0.14.6.gem (100%)
Fetching: rubyzip-0.9.5.gem (100%)
Fetching: zippy-0.1.0.gem (100%)
Fetching: multipart-post-1.1.4.gem (100%)
Fetching: highline-1.6.8.gem (100%)
Fetching: pgxn_utils-0.1.3.gem (100%)

  PGXN Utils version 0.1.3 was installed!

  Issues? Please visit: https://github.com/guedes/pgxn-utils/issues

  PGXN Client found. Cool!
  PGXN Meta Validator found. Cool!

  Thank you for use this tool!

 \ Regards, Dickson S. Guedes

Successfully installed json-1.5.4
Successfully installed thor-0.14.6
Successfully installed rubyzip-0.9.5
Successfully installed zippy-0.1.0
Successfully installed multipart-post-1.1.4
Successfully installed highline-1.6.8
Successfully installed pgxn_utils-0.1.3
7 gems installed

First run:

$ pgxn-utils 
Invalid gemspec in [/var/lib/gems/1.8/specifications/json-1.5.4.gemspec]: invalid date format in specification: "2011-08-31 00:00:00.000000000Z"
Invalid gemspec in [/var/lib/gems/1.8/specifications/pgxn_utils-0.1.3.gemspec]: invalid date format in specification: "2011-05-06 00:00:00.000000000Z"
/usr/lib/ruby/vendor_ruby/1.8/rubygems.rb:926:in `report_activate_error': Could not find RubyGem pgxn_utils (>= 0) (Gem::LoadError)
    from /usr/lib/ruby/vendor_ruby/1.8/rubygems.rb:244:in `activate_dep'
    from /usr/lib/ruby/vendor_ruby/1.8/rubygems.rb:236:in `activate'
    from /usr/lib/ruby/vendor_ruby/1.8/rubygems.rb:1307:in `gem'
    from /usr/local/bin/pgxn-utils:18

Fix is easy: had to change /var/lib/gems/1.8/specifications/pgxn_utils-0.1.3.gemspec and replace the date with 2011-05-06. Had to do it in the json gemspec too, but that's out of your control I guess.

Owner

guedes commented Apr 15, 2012

I couldn't reproduce that. Could you try last version?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment