Common Errors

dsyer edited this page Oct 17, 2011 · 6 revisions
Clone this wiki locally

Common errors

All this errors will be fixed in the next versions, but until it is done, I'm putting here some alternatives to you.

Command not found after gem install

~$ pgxn_utils
pgxn_utils: command not found

Just put /var/lib/gems/1.8/bin in your $PATH variable

JSON not found

~$ /var/lib/gems/1.8/bin/pgxn_utils 
/usr/lib/ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_require': no such file to load -- json     (LoadError)
	from /usr/lib/ruby/1.8/rubygems/custom_require.rb:31:in `require'
	from /var/lib/gems/1.8/gems/pgxn_utils-0.1.1/lib/pgxn_utils.rb:2
	from /usr/lib/ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_require'
	from /usr/lib/ruby/1.8/rubygems/custom_require.rb:31:in `require'
	from /var/lib/gems/1.8/gems/pgxn_utils-0.1.1/bin/pgxn_utils:4
	from /var/lib/gems/1.8/bin/pgxn_utils:19:in `load'
	from /var/lib/gems/1.8/bin/pgxn_utils:19

Just do a sudo apt-get install json

JSON gem doesn't install

~$ sudo gem install json
Building native extensions.  This could take a while...
ERROR:  Error installing json:
	ERROR: Failed to build gem native extension.

/usr/bin/ruby1.8 extconf.rb
extconf.rb:1:in `require': no such file to load -- mkmf (LoadError)
	from extconf.rb:1

Just do sudo gem install ruby ruby1.8-dev

No such file to load

~$ /var/lib/gems/1.8/gems/pgxn_utils-0.1.1/bin/pgxn_utils
/var/lib/gems/1.8/gems/pgxn_utils-0.1.1/lib/pgxn_utils.rb:1:in `require': no such file to load -- thor  (LoadError)
	from /var/lib/gems/1.8/gems/pgxn_utils-0.1.1/lib/pgxn_utils.rb:1
	from /var/lib/gems/1.8/gems/pgxn_utils-0.1.1/bin/pgxn_utils:4:in `require'
	from /var/lib/gems/1.8/gems/pgxn_utils-0.1.1/bin/pgxn_utils:4

Just run /var/lib/gems/1.8/bin/pgxn_utils instead of /var/lib/gems/1.8/gems/pgxn_utils-0.1.1/bin/pgxn_utils