Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Unable to build 5.18 and earlier #448

Open
pwr22 opened this issue Jan 16, 2015 · 6 comments
Open

Unable to build 5.18 and earlier #448

pwr22 opened this issue Jan 16, 2015 · 6 comments

Comments

@pwr22
Copy link

@pwr22 pwr22 commented Jan 16, 2015

I'm trying to build on Ubuntu 14.10 with Perlbrew 0.72, they all fail due to differing test failures

I'm thinking of firing up a virtual box to find out if it's something screwy with the machine and container I'm using

@pwr22

This comment has been minimized.

Copy link
Author

@pwr22 pwr22 commented Jan 16, 2015

5.20.1 and 5.21.7 both build fine

@pwr22

This comment has been minimized.

Copy link
Author

@pwr22 pwr22 commented Jan 31, 2015

Tested on a different Ubuntu 14.10 machine and the results are the same

@christopherraa

This comment has been minimized.

Copy link

@christopherraa christopherraa commented Feb 17, 2015

I believe this is due to 14.10 having GCC4.9 as default. A lot of perl-versions seem to be suffering. One thread on the subject in the Debian bugtracker. I am seeing the exact same behaviour.

@wols

This comment has been minimized.

Copy link

@wols wols commented Oct 19, 2015

Hi, on Gentoo I switched back and perlbrew -v install 5.10.1 runs :-)

[1] x86_64-pc-linux-gnu-4.8.5 *
[2] x86_64-pc-linux-gnu-4.9.3

perlbrew AND local install make test breaks ago:

Failed 4 tests out of 1607, 99.75% okay.
    comp/cpp.t
    op/numconvert.t
    op/range.t
    run/switchPx.t
@KES777

This comment has been minimized.

Copy link

@KES777 KES777 commented Nov 3, 2016

I have problems to install perl-5.12.5 also;

op/rand.t ......................................................... ok
# Failed at op/range.t line 289
# Failed at op/range.t line 290
#      got undef
# expected "-9223372036854775807"
...
Test Summary Report
-------------------
op/numconvert.t                                                 (Wstat: 0 Tests: 1440 Failed: 12)
  Failed tests:  104, 108, 112, 136, 140, 144, 152, 156
                160, 168, 172, 176
op/range.t                                                      (Wstat: 0 Tests: 141 Failed: 25)
  Failed tests:  84-95, 99-111
op/stash.t                                                      (Wstat: 0 Tests: 31 Failed: 0)
  TODO passed:   26
Files=1802, Tests=349279, 528 wallclock secs (37.09 usr  5.93 sys + 239.63 cusr 18.31 csys = 300.96 CPU)
Result: FAIL

Seems it is related to this and gcc-4.9
But:

$ gcc --version
gcc (Ubuntu 5.4.0-6ubuntu1~16.04.2) 5.4.0 20160609
Copyright (C) 2015 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
$ uname -a
Linux work 4.4.0-43-generic #63-Ubuntu SMP Wed Oct 12 13:48:03 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

Is there any steps I should done to install perl-5.12.5?

@gugod

This comment has been minimized.

Copy link
Owner

@gugod gugod commented Nov 4, 2016

@KES777 I noticed the same error when installing perl-5.8.8 on debian 8. Perhaps it also happens on recent perl versions. But basically this means we need to add something to patchperl for recent linux distro.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
5 participants
You can’t perform that action at this time.