Browse files

Tweaked expected module output to account for the change in default f…

…ormat in Test::Builder 1.005000_005.
  • Loading branch information...
1 parent cdf04d9 commit ce1e898183f05f58e57617d28683f18e10b7bed4 @guillaumeaubert committed May 16, 2012
View
4 t/20-ok_versions-sync.t
@@ -23,11 +23,13 @@ ok(
'Add the test lib/ directory to @INC.',
);
+test_out( '1..5')
+ if $Test::More::VERSION >= 1.005000005;
test_out( 'ok 1 - No MANIFEST.SKIP found, skipping.' );
test_out( 'ok 2 - The MANIFEST file is present at the root of the distribution.' );
test_out( 'ok 3 - Retrieve MANIFEST file.' );
test_out( ' TAP version 13' )
- if $Test::More::VERSION >= 1.005;
+ if $Test::More::VERSION >= 1.005 && $Test::More::VERSION < 1.005000005;
test_out( ' 1..4' );
test_out( ' ok 1 - use TestModule1;' );
test_out( ' ok 2 - Module TestModule1 declares a version.' );
View
5 t/21-ok_versions-desync.t
@@ -23,12 +23,13 @@ ok(
'Add the test lib/ directory to @INC.',
);
-
+test_out( '1..5')
+ if $Test::More::VERSION >= 1.005000005;
test_out( 'ok 1 - No MANIFEST.SKIP found, skipping.' );
test_out( 'ok 2 - The MANIFEST file is present at the root of the distribution.' );
test_out( 'ok 3 - Retrieve MANIFEST file.' );
test_out( ' TAP version 13' )
- if $Test::More::VERSION >= 1.005;
+ if $Test::More::VERSION >= 1.005 && $Test::More::VERSION < 1.005000005;
test_out( ' 1..4' );
test_out( ' ok 1 - use TestModule1;' );
test_out( ' ok 2 - Module TestModule1 declares a version.' );
View
4 t/22-ok_versions-modules_list.t
@@ -23,9 +23,11 @@ ok(
'Add the test lib/ directory to @INC.',
);
+test_out( '1..3')
+ if $Test::More::VERSION >= 1.005000005;
test_out( 'ok 1 - modules list isa ARRAY' );
test_out( ' TAP version 13' )
- if $Test::More::VERSION >= 1.005;
+ if $Test::More::VERSION >= 1.005 && $Test::More::VERSION < 1.005000005;
test_out( ' 1..4' );
test_out( ' ok 1 - use TestModule1;' );
test_out( ' ok 2 - Module TestModule1 declares a version.' );
View
3 t/23-ok_versions-empty_list.t
@@ -7,6 +7,9 @@ use Test::More tests => 1;
use Test::Dist::VersionSync;
use Test::Builder::Tester;
+
+test_out( '1..3')
+ if $Test::More::VERSION >= 1.005000005;
test_out( 'ok 1 - modules list isa ARRAY' );
test_out( 'ok 2 # skip No module found in the distribution.' );
test_out( 'ok 3 # skip No module found in the distribution.' );
View
2 t/24-ok_versions-missing_manifest.t
@@ -23,6 +23,8 @@ ok(
'Add the test lib/ directory to @INC.',
);
+test_out( '1..5')
+ if $Test::More::VERSION >= 1.005000005;
test_out( 'ok 1 - No MANIFEST.SKIP found, skipping.' );
test_out( 'not ok 2 - The MANIFEST file is present at the root of the distribution.' );
test_out( 'ok 3 # skip MANIFEST is missing, cannot retrieve list of files.' );
View
4 t/25-ok_versions-missing_version.t
@@ -23,11 +23,13 @@ ok(
'Add the test lib/ directory to @INC.',
);
+test_out( '1..5')
+ if $Test::More::VERSION >= 1.005000005;
test_out( 'ok 1 - No MANIFEST.SKIP found, skipping.' );
test_out( 'ok 2 - The MANIFEST file is present at the root of the distribution.' );
test_out( 'ok 3 - Retrieve MANIFEST file.' );
test_out( ' TAP version 13' )
- if $Test::More::VERSION >= 1.005;
+ if $Test::More::VERSION >= 1.005 && $Test::More::VERSION < 1.005000005;
test_out( ' 1..4' );
test_out( ' ok 1 - use TestModule1;' );
test_out( ' ok 2 - Module TestModule1 declares a version.' );

0 comments on commit ce1e898

Please sign in to comment.