[Notice] graceful-fs deprecation warning #1571

Open
phated opened this Issue Mar 17, 2016 · 5 comments

Projects

None yet

2 participants

@phated
Member
phated commented Mar 17, 2016 edited

We are aware of the graceful-fs deprecation warning upon install of gulp 3.x.

This is due to:

  1. A transitive graceful-fs devDependency

We are unable to upgrade due to API breaking changes.

There is nothing wrong with the dependency, especially since it is only used in development. We will be updating or removing it in gulp 4 and the message will go away.

Please do not open issues about this topic.
Thank you,
-The gulp team

@phated phated added the notice label Mar 17, 2016
@phated phated locked and limited conversation to collaborators Mar 17, 2016
@phated phated modified the milestone: gulp 4 Apr 5, 2016
@phated
Member
phated commented Aug 16, 2016

This should be no longer an issue due to the amazing work by @thealphanerd at isaacs/node-graceful-fs@07701dc

I'll leave this open until I have a chance to verify. Unlocking incase anyone has a chance to test it out.

@phated phated unlocked this conversation Aug 16, 2016
@piotr-cz

how to test?

@phated
Member
phated commented Aug 16, 2016

Looks like there was a follow up at isaacs/node-graceful-fs@07701dc#commitcomment-18659275

Locking again with the same conclusion. Sorry everyone.

@phated phated locked and limited conversation to collaborators Aug 16, 2016
@phated
Member
phated commented Aug 24, 2016

As per #1760 (comment) - It looks like I can close this now that graceful-fs 3.0.10 has been released.

@phated phated closed this Aug 24, 2016
@phated
Member
phated commented Oct 6, 2016

Looks like I need to reopen this 😦

@phated phated reopened this Oct 6, 2016
Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.