Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

After update to Node 11.0.0 running Gulp exits with 'ReferenceError: internalBinding is not defined' #2246

Closed
rpkoller opened this issue Oct 24, 2018 · 11 comments

Comments

@rpkoller
Copy link

commented Oct 24, 2018

I am running MacOS 10.13.6 and use Homebrew to keep Node and NPM up to date. I've updated to Node '11.0.0' and NPM '6.4.1' today. I've installed Gulp '3.9.1' globally. When i try to run Gulp in my project folder i get the following error (before '11.0.0' everything worked flawlessly):

$> gulp
fs.js:25
'use strict';
^

ReferenceError: internalBinding is not defined
    at fs.js:25:1
    at req_ (/Users/danton/SitesLocal/myapp/app/public/node_modules/natives/index.js:140:5)
    at Object.req [as require] (/Users/danton/SitesLocal/myapp/app/public/node_modules/natives/index.js:54:10)
    at Object.<anonymous> (/Users/danton/SitesLocal/myapp/app/public/node_modules/graceful-fs/fs.js:1:99)
    at Module._compile (internal/modules/cjs/loader.js:707:30)
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:718:10)
    at Module.load (internal/modules/cjs/loader.js:605:32)
    at tryModuleLoad (internal/modules/cjs/loader.js:544:12)
    at Function.Module._load (internal/modules/cjs/loader.js:536:3)
    at Module.require (internal/modules/cjs/loader.js:643:17)

Is it possible that the error goes back to the following change in Node '11.0.0'

nodejs/node#22146

So that changes have to be applied to graceful-fs and or natives? If you need any further infos let me know. Thanks r.

@contra

This comment has been minimized.

Copy link
Member

commented Oct 24, 2018

@rpkoller When you update node you need to run rm -rf node_modules && npm install to rebuild/reinstall your native modules against your new node version.

@contra contra closed this Oct 24, 2018
@rpkoller

This comment has been minimized.

Copy link
Author

commented Oct 24, 2018

@contra at first thanks for the fast answer and sorry didn't knew that you have to rebuild/reinstall against the new version :/ will try when i am back home. thanks again!

@phated

This comment has been minimized.

Copy link
Member

commented Oct 24, 2018

I also wouldn't recommend using 3.9.1 with node 11 - they have been threatening to break that version forever and who knows if they finally did it. You can install 4.0.0 with npm install gulp@next but you'll likely need to migrate any existing gulpfile to the new syntax (check out our new docs!)

@sidharth016

This comment has been minimized.

Copy link

commented Oct 31, 2018

I was using yarn and had updated it then i suddenly started encountering this problem.
i just ran yarn upgrade in my project folder
Everything works fine

@shamotj

This comment has been minimized.

Copy link

commented Nov 2, 2018

This issue is not resolved. Reinstalling node_modules doesn't help.

@Tha14

This comment has been minimized.

Copy link

commented Nov 2, 2018

I am also experiencing the same issue, as well.

@mgdhs

This comment has been minimized.

Copy link

commented Nov 4, 2018

Update to natives@1.1.6. Run npm install natives@1.1.6.

@mootz

This comment has been minimized.

Copy link

commented Nov 4, 2018

Update to natives@1.1.6. Run npm install natives@1.1.6.

it works, thank you!

@shamotj

This comment has been minimized.

Copy link

commented Nov 5, 2018

I confirm, this works.

@josefarrugia

This comment has been minimized.

Copy link

commented Nov 5, 2018

Update to natives@1.1.6. Run npm install natives@1.1.6.

This definitely works! I think you've saved me hours of looking for a solution.

@uxuf

This comment has been minimized.

Copy link

commented Nov 5, 2018

Update to natives@1.1.6. Run npm install natives@1.1.6.

Yes, worked for me too

@gulpjs gulpjs locked and limited conversation to collaborators Nov 5, 2018
h44z referenced this issue in h44z/desktop Nov 25, 2018
Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
Projects
None yet
10 participants
You can’t perform that action at this time.