Permalink
Browse files

Check lein version. LT does not build on older lein versions

  • Loading branch information...
1 parent 258600c commit 2b96338e61769327d119f2ee8db7e79f2b555754 @gunnarahlberg committed Jan 18, 2014
Showing with 13 additions and 0 deletions.
  1. +3 −0 linux_deps.sh
  2. +4 −0 osx_deps.sh
  3. +6 −0 windows_deps.sh
View
@@ -1,6 +1,9 @@
#!/usr/bin/env bash
# Check if lein is installed
lein version >/dev/null 2>&1 || { echo >&2 "Please install leiningen before running this script."; exit 1; }
+if [ "$(echo `lein version` | grep 'Leiningen 1.\|2.0')" ]; then
+ echo "lein version must be 2.1 or above. Do a lein upgrade first"; exit 1;
+fi
echo "### Fetching binaries ###"
BITS=""
View
@@ -1,5 +1,9 @@
# Check if lein is installed
lein version >/dev/null 2>&1 || { echo >&2 "Please install leiningen before running this script."; exit 1; }
+if [ "$(echo `lein version` | grep 'Leiningen 1.\|2.0')" ]; then
+ echo "lein version must be 2.1 or above. Do a lein upgrade first"; exit 1;
+fi
+
#get the LightTable.app binary
curl -O http://d35ac8ww5dfjyg.cloudfront.net/playground/bins/0.6.0/LightTableMac.zip
View
@@ -1,3 +1,9 @@
+# Check if lein is installed
+lein version >/dev/null 2>&1 || { echo >&2 "Please install leiningen before running this script."; exit 1; }
+if [ "$(echo `lein version` | grep 'Leiningen 1.\|2.0')" ]; then
+ echo "lein version must be 2.1 or above. Do a lein upgrade first"; exit 1;
+fi
+
ZIPFILE=LightTableWin.zip
echo "### Fetching binaries ###"
curl -O http://d35ac8ww5dfjyg.cloudfront.net/playground/bins/0.6.0/$ZIPFILE

0 comments on commit 2b96338

Please sign in to comment.