Skip to content
Permalink
Branch: master
Find file Copy path
Find file Copy path
Fetching contributors…
Cannot retrieve contributors at this time
75 lines (43 sloc) 2.92 KB
title permalink
Awesome-3-RHEL6
/Awesome-3-RHEL6/

Steps to build and install Awesome 3 on RHEL6 Beta

Prerequisite

  • Install Development tools and Desktop Platform Development.

 yum groupinstall -y 'Development tools' 'Desktop Platform Development'

  • Install ImageMagick, startup-notification and readline.

 yum install -y ImageMagick startup-notification startup-notification-devel readline readline-devel

  • Set PKG_CONFIG_PATH to include /usr/local/lib/pkgconfig/. Note, if you open a new terminal/session, don't forget to set this variable.

 export PKG_CONFIG_PATH="/usr/local/lib/pkgconfig/"

  • Get cmake, build and install it. Tested with version 2.8.1.

 ./bootstrap && make && make install

  • Get gperf, build and install it. Tested with version 3.0.4.

 ./configure && make && make install

  • Get imlib2, build and install it. Tested with version 1.4.4.

 ./configure && make && make install

  • Get libev, build and install it. Tested with version 3.9.

 ./configure && make && make install

 ./configure && make && make install

  • Get libxdg-basedir, build and install it. Tested with version 1.1.0.

 ./configure && make && make install

  • Get Lua, build and install it. Tested with version 5.1.4.

 make linux && make install

  • Get Cairo, build and install it. Tested with version 1.8.10.

 ./configure --enable-xcb && make && make install

Awesome

  • Get Awesome, build and install it. Tested with version 3.4.5.

 make && make install

After Installation

  • Awesome is installed in /usr/local/.
  • You need a configuration file for awesome in your home (~/.config/awesome/rc.lua). The default is in /usr/local/etc/xdg/awesome/.
  • To run Awesome you have to add /usr/local/lib to /etc/ld.so.conf and run ldconfig, otherwise Awesome is not able to find some libraries.

Notes

  • Documentation of Awesome isn't available. To build you need xmlto, asciidoc and luadoc.
  • I tried to rebuild cairo with xcb enabled from SRC-RPM, but no luck I got a error about missing xcb. Furthermore a update of the cairo package from Red Hat will break the awesome build.
You can’t perform that action at this time.