ES6 Loader Plugin for RequireJS
JavaScript
Latest commit 1e05b2c Apr 15, 2013 @guybedford Merge pull request #1 from dcherman/add-readme-link
Add a link to the AMD-Loader plugin in README
Permalink
Failed to load latest commit information.
test sanitize Apr 7, 2013
README.md Add a link to the AMD-Loader plugin in README Apr 15, 2013
component.json alpha Apr 7, 2013
es6.js alpha Apr 7, 2013
package.json alpha Apr 7, 2013
traceur-compiler.js alpha Apr 7, 2013

README.md

ES6 Plugin

Load ES6 modules using Traceur, using RequireJS plugin syntax:

  define(['es6!some-module'], function(someModule) { ... });

For language features, see the Traceur documentation.

Installation

Needs AMD-Loader base plugin to work. This is automatically installed with Bower or Volo, otherwise it must be downloaded manually.

  volo add guybedford/es6
  bower install es6

When using bower, add the paths (or map) configuration:

  paths: {
    es6: 'es6/es6',
    'amd-loader': 'amd-loader/amd-loader'
  }