Skip to content
Browse files

Updated deps, updated docs, dropped legacy rubies

  • Loading branch information...
1 parent 71f592e commit 67d13276b3123e38426062f802cff7da65ce3498 @arax arax committed Aug 15, 2013
Showing with 8 additions and 40 deletions.
  1. +0 −8 Gemfile
  2. +6 −8 README.md
  3. +0 −21 ext/mkrf_conf.rb
  4. +2 −3 occi.gemspec
View
8 Gemfile
@@ -6,11 +6,3 @@ group :development do
gem 'warbler', :git => 'git://github.com/jruby/warbler.git', :ref => 'ce3ce4df137504822e4cbb9399dee7e7dd767c44'
gem 'rubygems-tasks', :git => 'git://github.com/postmodern/rubygems-tasks.git'
end
-
-platforms :jruby do
- gem 'jruby-openssl' if ((defined? JRUBY_VERSION) && (JRUBY_VERSION.split('.')[1].to_i < 7))
-end
-
-platforms :ruby_18 do
- gem 'oniguruma'
-end
View
14 README.md
@@ -21,23 +21,21 @@ Requirements
------------
### Ruby
-* at least version 1.8.7 is required
-* Ruby 1.9.3+ is recommended
-* RubyGems installed
-* rake installed (e.g., `gem install rake`)
+* Ruby 1.9.3 is required
+* RubyGems have to be installed
+* Rake has to be installed (e.g., `gem install rake`)
### Libraries/packages
* libxslt1-dev/libxslt-devel
* libxml2-dev/libxml2-devel
-* **only if using Ruby 1.8.7:** libonig-dev/oniguruma-devel (Linux) or oniguruma (Mac)
### Examples
For distros based on Debian:
~~~
-apt-get install ruby rubygems ruby-dev libxslt1-dev libxml2-dev libonig-dev
+apt-get install ruby rubygems ruby-dev libxslt1-dev libxml2-dev
~~~
For distros based on RHEL:
~~~
-yum install libxml2-devel libxslt-devel ruby-devel openssl-devel gcc gcc-c++ ruby rubygems oniguruma-devel
-~~~
+yum install libxml2-devel libxslt-devel ruby-devel openssl-devel gcc gcc-c++ ruby rubygems
+~~~
View
21 ext/mkrf_conf.rb
@@ -1,21 +0,0 @@
-require 'rubygems'
-require 'rubygems/command.rb'
-require 'rubygems/dependency_installer.rb'
-
-begin
- Gem::Command.build_args = ARGV
-rescue NoMethodError
- # do nothing but warn the user
- warn "Gem::Command doesn't have a method named 'build_args'!"
-end
-
-warn 'Installing platform-specific dependencies.'
-
-warn 'Installing the most recent version of \'rake\''
-inst = Gem::DependencyInstaller.new
-inst.install "rake"
-
-# create dummy rakefile to indicate success
-f = File.open(File.join(File.dirname(__FILE__), "Rakefile"), "w")
-f.write "task :default\n"
-f.close
View
5 occi.gemspec
@@ -13,12 +13,11 @@ Gem::Specification.new do |gem|
gem.summary = %q{Executable OCCI client}
gem.homepage = 'https://github.com/gwdg/rOCCI'
gem.license = 'Apache License, Version 2.0'
- gem.extensions = 'ext/mkrf_conf.rb'
- gem.add_dependency 'occi-cli', '~> 4.0.1'
+ gem.add_dependency 'occi-cli', '~> 4.1.0'
gem.add_development_dependency 'rake'
- gem.required_ruby_version = ">= 1.8.7"
+ gem.required_ruby_version = ">= 1.9.3"
gem.post_install_message = "This gem is just a wrapper providing backward compatibility and might be removed in the future! Please, consider using 'occi-cli' directly."
end

0 comments on commit 67d1327

Please sign in to comment.
Something went wrong with that request. Please try again.