Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
A Ruby OCCI Framework

This branch is 6 commits behind master

Fetching latest commit…

Cannot retrieve the latest commit at this time

Failed to load latest commit information.
lib/occi
.gitignore
AUTHORS
Gemfile
LICENSE
README.md
Rakefile
occi.gemspec

README.md

rOCCI - A Ruby OCCI Framework

Build Status Dependency Status Gem Version Code Climate

rOCCI framework now consists of the following separately maintained parts:

You can still install it by running:

gem install rake
gem install occi

Requirements

Ruby

  • Ruby 1.9.3 is required
  • RubyGems have to be installed
  • Rake has to be installed (e.g., gem install rake)

Libraries/packages

  • libxslt1-dev/libxslt-devel
  • libxml2-dev/libxml2-devel

Examples

For distros based on Debian:

apt-get install ruby rubygems ruby-dev libxslt1-dev libxml2-dev

For distros based on RHEL:

yum install libxml2-devel libxslt-devel ruby-devel openssl-devel gcc gcc-c++ ruby rubygems
Something went wrong with that request. Please try again.