Permalink
Browse files

JRuby, 1.8.6 don't seem to like the ~> syntax in Gemfiles from gemspecs

due to the YAML parsers.
Since these are dev dependencies only, for now we'll hardcode to the
latest version until we can find a workaround.
  • Loading branch information...
ragaskar committed Apr 15, 2011
1 parent dc144e0 commit 338fa6a149783410cd71251cc6b887a0f47deccb
Showing with 4 additions and 4 deletions.
  1. +4 −4 jasmine.gemspec
View
@@ -20,17 +20,17 @@ Gem::Specification.new do |s|
s.rdoc_options = ["--charset=UTF-8"]
if ENV['RAILS_VERSION'] == 'pojs-rspec1'
- s.add_development_dependency 'rspec', '~> 1.3.1'
+ s.add_development_dependency 'rspec', '1.3.1'
s.add_development_dependency 'rake-tasks'
s.add_development_dependency 'rack', "1.1" if ENV["RUBY_VERSION"] =~ /1\.8\.6/
elsif ENV['RAILS_VERSION'] == 'pojs-rspec2'
- s.add_development_dependency 'rspec', '~> 2.5.0'
+ s.add_development_dependency 'rspec', '>= 2.5.0'
s.add_development_dependency 'rake-tasks'
s.add_development_dependency 'rack', "1.1" if ENV["RUBY_VERSION"] =~ /1\.8\.6/
elsif ENV['RAILS_VERSION'] == 'rails2'
# for development & test of Rails 2 Generators
- s.add_development_dependency 'rspec', '~> 1.3.1'
- s.add_development_dependency 'rails', '~> 2.3.10'
+ s.add_development_dependency 'rspec', '1.3.1'
+ s.add_development_dependency 'rails', '2.3.11'
s.add_development_dependency 'rack', '1.1'
else
# for development & test of Rails 3 Generators

0 comments on commit 338fa6a

Please sign in to comment.