Package for analysing and characterising gravitational wave data in python
Python Shell Tcl
duncanmmacleod Merge pull request #800 from scottcoughlin2014/develop
Update to fftgram method. This now outputs a complex spectrogram
Latest commit e8fca1a Jul 18, 2018
Permalink
Failed to load latest commit information.
.circleci circleci: use simpler variable setting Jun 18, 2018
bin cli: provided ordered dict of products in gwpy.cli May 15, 2018
ci ci: fixed bug in coveralls.sh Jul 4, 2018
debian glue: move to optional dependency May 18, 2018
docs docs: improved `gwpy.plot` docs Jun 14, 2018
etc etc: simplified spec file for no python3 Jul 4, 2018
examples examples: fixed spectrogram in open-data-spectrogram.py Jun 21, 2018
gwpy Merge pull request #800 from scottcoughlin2014/develop Jul 18, 2018
.codebeatignore exclude gwpy.plotter from code review Jun 14, 2018
.codeclimate.yml codeclimate: allow 8 arguments for a func Jun 14, 2018
.gitattributes .gitattributes: remove version.py Apr 29, 2016
.gitignore Merge pull request #747 from duncanmmacleod/cli-args Jun 6, 2018
.pep8speaks.yml pep8: fixed some style issues May 16, 2018
.pylintrc .pylintrc: added 'u' as acceptable variable name Feb 23, 2018
.travis.yml ci: more updates to test/coveralls Jul 4, 2018
CONTRIBUTING.md CONTRIBUTING.md: added contribution guide Mar 29, 2017
LICENSE LICENSE: added GNU v3 license to all files Oct 18, 2013
MANIFEST.in README: moved README back to markdown syntax [ci skip] Jun 25, 2018
README.md README: moved README back to markdown syntax [ci skip] Jun 25, 2018
bandit.yml bandit.yml: added codacy configuration file Jul 3, 2018
requirements-dev.txt separated requirements into files Jul 4, 2018
requirements-doc.txt separated requirements into files Jul 4, 2018
requirements-test.txt requirements-test: don't install coveralls Jul 4, 2018
requirements.txt glue: move to optional dependency May 18, 2018
setup.cfg setup.cfg: don't exclude tests from coverage Jun 16, 2018
setup.py setup.py: updated sqlparse requirement Jul 4, 2018
setup_utils.py setup_utils.py: updated for pip 10 May 18, 2018
versioneer.py versioneer: updated to 0.18 Nov 13, 2017

README.md

GWpy is a collaboration-driven Python package providing tools for studying data from ground-based gravitational-wave detectors.

GWpy provides a user-friendly, intuitive interface to the common time-domain and frequency-domain data produced by the LIGO and Virgo observatories and their analyses, with easy-to-follow tutorials at each step.

https://gwpy.github.io

Release status

PyPI version Macports version

DOI License Supported Python versions Research software impact

Build Status Coverage Status

Development status

Build Status dev Coverage Status dev Maintainability

Installation

To install, you can do:

pip install gwpy

You can test your installation, and its version by

python -c "import gwpy; print(gwpy.__version__)"