New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Problems with Unsync option in version 1.7 #270

Closed
rcoss opened this Issue Jun 13, 2013 · 13 comments

Comments

Projects
None yet
4 participants
@rcoss
Copy link

rcoss commented Jun 13, 2013

Upgraded server and clients to version 1.7. Server 64bit Clients Linux 64bit, Windows 7 64bit, Windows XP 32bit. All clients show the same problem:

C: action on local client
S: action on server web page

S) Unsync library from server list. Confirm. OK
C) Start seafile on client. Error can´t sync . OK
C) Unsync the same library from client. OK
C) Download and Sync same library and same local folder. Seems OK, but after downloading, seaf-deamon.exe crashes. (Win and Linux)
C) Restart client. NO libraries registered with client.
S) Library (and client) IS registered with server.
S) Unsync again. OK
C) Download and sync w/local folder. ERR="Failed to merge with local file changes"
( no local file changes)
S) Unsync again (because again registered). OK
C) Remove library (local folder) and then Download only. ERR="Failed to create local files"
S) Unsync again
C) Stop client. OK
C) Remove hidden seafile-data folder.
C) Start client. INIT and CONFIG. OK
C) Download and Sync w/ exist. folder (all libraries!) . First lib OK, Second lib ERR="Failed to create local files"
S) Unsync both
C) Stop client, remove seafile-data ,remove local libraries, Start client. INIT CONFIG OK
C) Download (only) both libraries OK.

Another (minor) problem is that after upgrading server from 1.6.1 to 1.7.0 the list of clients in the server is populated with Unknown, presumably from clients already registered, but after unsync and sync again many duplicates appear.

@killing

This comment has been minimized.

Copy link
Member

killing commented Jun 14, 2013

This is a bug introduced by changes in 1.7. I've fixed it and will soon release a new version. Thanks for reporting.
In 1.6, the detailed client information, such as IP, name are not stored on the server. That's why you see Unknown.

@killing

This comment has been minimized.

Copy link
Member

killing commented Jun 24, 2013

The problem is fixed in 1.7.2 client.

@killing killing closed this Jun 24, 2013

@HenriWahl

This comment has been minimized.

Copy link

HenriWahl commented Jul 12, 2013

Can you please provide the latest 1.7.3 source code for Linux because the current 1.7.1.1 produces the same problem? Thanks!

@freeplant

This comment has been minimized.

Copy link
Member

freeplant commented Jul 12, 2013

It should be fixed in 1.7.1.1. Do you use a fresh install?

@HenriWahl

This comment has been minimized.

Copy link

HenriWahl commented Jul 12, 2013

How fresh do you mean? Binary-wise or config/folder-wise?

@freeplant

This comment has been minimized.

Copy link
Member

freeplant commented Jul 12, 2013

Did you deleted the old client's data?

2013/7/12 HenriWahl notifications@github.com

How fresh do you mean? Binary-wise or config/folder-wise?


Reply to this email directly or view it on GitHubhttps://github.com//issues/270#issuecomment-20868662
.

@HenriWahl

This comment has been minimized.

Copy link

HenriWahl commented Jul 12, 2013

just the library folder ~/Seafile/Library. Anything more to delete?

@freeplant

This comment has been minimized.

Copy link
Member

freeplant commented Jul 12, 2013

You have to remove seafile and seafile-data directories.

2013/7/12 HenriWahl notifications@github.com

just the library folder ~/Seafile/Library. Anything more to delete?


Reply to this email directly or view it on GitHubhttps://github.com//issues/270#issuecomment-20868759
.

@HenriWahl

This comment has been minimized.

Copy link

HenriWahl commented Jul 12, 2013

When syncing libraries from other servers too will they be also affected? I mean, when deleting seafile-data?

@freeplant

This comment has been minimized.

Copy link
Member

freeplant commented Jul 12, 2013

No, it is a local problem.

2013/7/12 HenriWahl notifications@github.com

When syncing libraries from other servers too will they be also affected?


Reply to this email directly or view it on GitHubhttps://github.com//issues/270#issuecomment-20868866
.

@HenriWahl

This comment has been minimized.

Copy link

HenriWahl commented Jul 12, 2013

Yes, I meant my synchronizations to other servers do also vanish?

@freeplant

This comment has been minimized.

Copy link
Member

freeplant commented Jul 12, 2013

You only need to delete seafile-data directory. All libraries in the client
will unsync from servers. Then you have to re-sync them manually, one by
one. Not convenient, but this is the only solution.

2013/7/12 HenriWahl notifications@github.com

Yes, I meant my synchronizations to other servers do also vanish?


Reply to this email directly or view it on GitHubhttps://github.com//issues/270#issuecomment-20871775
.

@HenriWahl

This comment has been minimized.

Copy link

HenriWahl commented Jul 12, 2013

OK. Thanks!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment