Splizard edited this page Apr 28, 2018 · 16 revisions

See installation.

Debian / Ubuntu

Before installing Ebiten, you might need these libraries:

  • libglu1-mesa-dev
  • libgles2-mesa-dev
  • libxrandr-dev
  • libxcursor-dev
  • libxinerama-dev
  • libxi-dev
  • libasound2-dev

To install the dependencies on Ubuntu, run

$ sudo apt install libglu1-mesa-dev libgles2-mesa-dev libxrandr-dev libxcursor-dev libxinerama-dev libxi-dev libasound2-dev

Ebiten is tested on Ubuntu Linux x64.

Fedora

If you wish to install Ebiten on Fedora you need to get dependencies equivalent to those above, if you don't have them already:

$ sudo dnf install mesa-libGLU-devel mesa-libGLES-devel libXrandr-devel libXcursor-devel libXinerama-devel libXi-devel alsa-lib-devel

Solus

To get the required dependencies, run this command:

$ sudo eopkg install libglu-devel libx11-devel libxrandr-devel libxinerama-devel libxcursor-devel libxi-devel alsa-lib-devel 
You can’t perform that action at this time.
You signed in with another tab or window. Reload to refresh your session. You signed out in another tab or window. Reload to refresh your session.
Press h to open a hovercard with more details.