Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Newer
Older
100644 30 lines (22 sloc) 0.879 kB
6efd009 @jamis part 2, rename switchtower -> capistrano
jamis authored
1 require './lib/capistrano/version'
f9da6db @jamis Initial commit of the new switchtower utility
jamis authored
2
3 Gem::Specification.new do |s|
4
6efd009 @jamis part 2, rename switchtower -> capistrano
jamis authored
5 s.name = 'capistrano'
824d22b @jamis Move switchtower to the tools directory, to decouple it from rails
jamis authored
6 s.version = PKG_VERSION
f9da6db @jamis Initial commit of the new switchtower utility
jamis authored
7 s.platform = Gem::Platform::RUBY
f303df3 @jamis Fix awkward spacing in gemspec file (closes #3888)
jamis authored
8 s.summary = <<-DESC.strip.gsub(/\n\s+/, " ")
414da79 @jamis THANKS file is not applicable anymore. Bring various other files up-t…
jamis authored
9 Capistrano is a utility and framework for executing commands in parallel
bdef53c @jamis Refactored CLI stuff. Improved help system.
jamis authored
10 on multiple remote machines, via SSH.
f9da6db @jamis Initial commit of the new switchtower utility
jamis authored
11 DESC
12
55e194c @jamis restore plugin extension mechanism, fix hostname problem for tunnelle…
jamis authored
13 s.files = Dir.glob("{bin,lib,examples,test}/**/*") + %w(README MIT-LICENSE CHANGELOG)
f9da6db @jamis Initial commit of the new switchtower utility
jamis authored
14 s.require_path = 'lib'
8e9d456 @jamis enable rdoc generation from the gem
jamis authored
15 s.has_rdoc = true
f9da6db @jamis Initial commit of the new switchtower utility
jamis authored
16
17 s.bindir = "bin"
c131e12 @jamis capify, not deployify
jamis authored
18 s.executables << "cap" << "capify"
f9da6db @jamis Initial commit of the new switchtower utility
jamis authored
19
f0fbbec @jamis make sure capistrano only tries to load Net::SSH and Net::SFTP versio…
jamis authored
20 s.add_dependency 'net-ssh', ">= #{Capistrano::Version::SSH_REQUIRED.join(".")}", "< 1.99.0"
21 s.add_dependency 'net-sftp', ">= #{Capistrano::Version::SFTP_REQUIRED.join(".")}", "< 1.99.0"
bdef53c @jamis Refactored CLI stuff. Improved help system.
jamis authored
22 s.add_dependency 'highline'
f9da6db @jamis Initial commit of the new switchtower utility
jamis authored
23
24 s.author = "Jamis Buck"
25 s.email = "jamis@37signals.com"
eb6b1ef @jamis point at new capistrano homepage
jamis authored
26 s.homepage = "http://www.capify.org"
f0fbbec @jamis make sure capistrano only tries to load Net::SSH and Net::SFTP versio…
jamis authored
27 s.rubyforge_project = "capistrano"
f9da6db @jamis Initial commit of the new switchtower utility
jamis authored
28
29 end
Something went wrong with that request. Please try again.