Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
A base library for Hoptoad error reporting
Ruby

Fetching latest commit…

Cannot retrieve the latest commit at this time

Failed to load latest commit information.
lib
test
.gitignore
LICENSE
README.md
Rakefile
toadhopper.gemspec

README.md

A base library for Hoptoad error reporting.

Toadhopper can be used to report plain old Ruby exceptions, or to build a framework-specific gem such as toadhopper-sinatra.

require 'toadhopper'

Toadhopper.api_key = "YOURAPIKEY"

error = begin; raise "Kaboom!"; rescue => e; e; end

puts Toadhopper.post!(error)

You can install it via rubygems:

gem install toadhopper

If you need to report different Hoptoad projects from the same Ruby process call a Toadhopper instance rather than the class methods:

require 'toadhopper'

error = begin; raise "Kaboom!"; rescue => e; e; end

puts Toadhopper("API key for project 1").post!(error)
puts Toadhopper("API key for project 2").post!(error)
Something went wrong with that request. Please try again.