Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Node >= 4 / es6 updates #93

Closed
mtharrison opened this issue Nov 6, 2015 · 2 comments
Closed

Node >= 4 / es6 updates #93

mtharrison opened this issue Nov 6, 2015 · 2 comments
Assignees
Milestone

Comments

@mtharrison
Copy link
Member

@mtharrison mtharrison commented Nov 6, 2015

Summary of changes required:

  • use strict
  • const and let where appropriate (linter will tell you where)
  • arrow functions where appropriate (linter will tell you where)
  • relevant updates to tests + docs
  • updating deps and engine in package.json
  • avoid self and += / -= (not optimized yet for let const)
@jaw187

This comment has been minimized.

Copy link
Contributor

@jaw187 jaw187 commented Nov 7, 2015

@mtharrison Thanks Matt, I'll take it from here.

outmoded/hapi-contrib#62

@jaw187 jaw187 self-assigned this Nov 7, 2015
@jaw187 jaw187 added this to the 4.0.0 milestone Nov 7, 2015
@jaw187

This comment has been minimized.

Copy link
Contributor

@jaw187 jaw187 commented Jan 5, 2016

Addressed by #102

@jaw187 jaw187 closed this Jan 5, 2016
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.