Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Update hapijs/subtext to 2.0.2 from 2.0.0 #2862

Closed
bpdp opened this issue Oct 20, 2015 · 8 comments
Closed

Update hapijs/subtext to 2.0.2 from 2.0.0 #2862

bpdp opened this issue Oct 20, 2015 · 8 comments
Assignees
Milestone

Comments

@bpdp
Copy link

@bpdp bpdp commented Oct 20, 2015

Installing 11.0.1 complain with this warning:

npm WARN unmet dependency /fakeproject/node_modules/hapi/node_modules/subtext requires qs@'4.x.x' but will load
npm WARN unmet dependency /fakeproject/node_modules/hapi/node_modules/qs,
npm WARN unmet dependency which is version 5.2.0

It was only WARN, but will it be fine?

@johnbrett
Copy link
Contributor

@johnbrett johnbrett commented Oct 20, 2015

Hi @bpdp, subtext works fine with qs@5.2.0, I've updated the qs dependency in the latest version of subtext.

@bpdp
Copy link
Author

@bpdp bpdp commented Oct 20, 2015

Hi @johnbrett - thanks. closing this issue.

@bpdp bpdp closed this Oct 20, 2015
@johnbrett johnbrett self-assigned this Oct 20, 2015
@bpdp
Copy link
Author

@bpdp bpdp commented Oct 21, 2015

Still happen in 11.0.2. In hapi package.json, the dep is subtext 2.x.x. AFAIK, this should fetch latest version of subtext (2.0.2), but it fetch 2.0.0 instead. Should we put ^2.x.x ?

@bpdp bpdp reopened this Oct 21, 2015
@hueniverse
Copy link
Contributor

@hueniverse hueniverse commented Oct 21, 2015

No. hapi comes with shrinkwrap. Will need to update it and publish a new version.

@bpdp
Copy link
Author

@bpdp bpdp commented Oct 22, 2015

thanks @hueniverse. will wait for that new version

@bpdp bpdp closed this Oct 22, 2015
@hueniverse hueniverse reopened this Oct 22, 2015
@baldmountain
Copy link

@baldmountain baldmountain commented Oct 23, 2015

For us the issue with this is the npm-shirnkwrap.json file specifies subtext 2.0.0 which uses qs@4.x.x but It should specify subtext 2.0.2 so qs@5.2.x from hapijs can be used.

I think the 11.0.2 release jusy needs npm shrinkwrap to be run. (Sorry, I'm still learning about npm and how to package things.)

@hueniverse hueniverse assigned hueniverse and unassigned johnbrett Oct 23, 2015
@hueniverse hueniverse added this to the 11.0.3 milestone Oct 23, 2015
@hueniverse hueniverse changed the title subtext requires qs@4.x.x but qs@5.2.0 installed Update hapijs/subtext to 2.0.2 from 2.0.0 Oct 23, 2015
@gergoerdosi
Copy link
Contributor

@gergoerdosi gergoerdosi commented Oct 28, 2015

@hueniverse Could you please release 11.0.3? It is not possible to create a shrinkwrap:

$ npm shrinkwrap
npm WARN unmet dependency /node_modules/hapi/node_modules/subtext requires qs@'4.x.x' but will load
npm WARN unmet dependency /node_modules/hapi/node_modules/qs,
npm WARN unmet dependency which is version 5.2.0
npm ERR! Darwin 15.0.0
npm ERR! argv "/usr/local/bin/node" "/usr/local/bin/npm" "shrinkwrap"
npm ERR! node v4.2.1
npm ERR! npm  v2.14.7

npm ERR! Problems were encountered
npm ERR! Please correct and try again.
npm ERR! invalid: qs@5.2.0 /node_modules/hapi/node_modules/qs
npm ERR! 
npm ERR! If you need help, you may report this error at:
npm ERR!     <https://github.com/npm/npm/issues>

npm ERR! Please include the following file with any support request:
npm ERR!     /npm-debug.log

@gergoerdosi
Copy link
Contributor

@gergoerdosi gergoerdosi commented Oct 29, 2015

No, don't do that. Master is still broken. We need subtext 2.0.2.

$ npm install hapijs/hapi
npm WARN unmet dependency /node_modules/hapi/node_modules/subtext requires qs@'4.x.x' but will load
npm WARN unmet dependency /node_modules/hapi/node_modules/qs,
npm WARN unmet dependency which is version 5.2.0
hapi@11.0.3 node_modules/hapi
├── cryptiles@2.0.5
├── ammo@1.0.1
├── heavy@3.0.1
├── catbox-memory@1.1.2
├── statehood@2.1.1
├── topo@1.1.0
├── boom@2.9.0
├── iron@2.1.3
├── peekaboo@1.0.0
├── items@1.1.0
├── kilt@1.1.1
├── accept@1.1.0
├── call@2.0.2
├── shot@1.7.0
├── hoek@2.16.3
├── catbox@6.0.0
├── qs@5.2.0
├── joi@6.8.1 (isemail@1.2.0, moment@2.10.6)
├── mimos@2.0.2 (mime-db@1.19.0)
└── subtext@2.0.1 (content@1.0.2, wreck@6.2.0, pez@1.0.0)

$ npm ls
npm WARN unmet dependency /node_modules/hapi/node_modules/subtext requires qs@'4.x.x' but will load
npm WARN unmet dependency /node_modules/hapi/node_modules/qs,
npm WARN unmet dependency which is version 5.2.0

└─┬ hapi@11.0.3 (git://github.com/hapijs/hapi.git#d3a6cf829b200a0c99eafefce291baf3189960ef)
  ├── accept@1.1.0
  ├── ammo@1.0.1
  ├── boom@2.9.0
  ├── call@2.0.2
  ├── catbox@6.0.0
  ├── catbox-memory@1.1.2
  ├── cryptiles@2.0.5
  ├── heavy@3.0.1
  ├── hoek@2.16.3
  ├── iron@2.1.3
  ├── items@1.1.0
  ├─┬ joi@6.8.1
  │ ├── isemail@1.2.0
  │ └── moment@2.10.6
  ├── kilt@1.1.1
  ├─┬ mimos@2.0.2
  │ └── mime-db@1.19.0
  ├── peekaboo@1.0.0
  ├── qs@5.2.0 invalid
  ├── shot@1.7.0
  ├── statehood@2.1.1
  ├─┬ subtext@2.0.1
  │ ├── content@1.0.2
  │ ├─┬ pez@1.0.0
  │ │ ├── b64@2.0.1
  │ │ └─┬ nigel@1.0.1
  │ │   └── vise@1.0.0
  │ └── wreck@6.2.0
  └── topo@1.1.0

npm ERR! invalid: qs@5.2.0 /node_modules/hapi/node_modules/qs

@lock lock bot locked as resolved and limited conversation to collaborators Jan 10, 2020
Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
5 participants