Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

9.0.0 Release Notes #523

Closed
geek opened this issue Feb 18, 2016 · 0 comments
Assignees
Milestone

Comments

@geek
Copy link
Member

@geek geek commented Feb 18, 2016

Summary

The only linter that ships with lab is now eslint. Additionally, support has been added for running custom linters.

  • Upgrade time: low - only people using jslint are impacted
  • Dependencies: low- removed an optional dependency

Migration List

If you are using jslint you can install lab-jslint in order to regain jslint support in your project. After you install the new dependency, you will need to change your lab arguments to include the path to the local lab-jslint runner.

Old jslint example:

lab -L -n jslint

New jslint example

lab -L -n node_modules/lab-jslint

If you are using eslint, there is no change required.

@geek geek self-assigned this Feb 18, 2016
@geek geek added this to the 9.0.0 milestone Feb 18, 2016
@geek geek closed this Feb 18, 2016
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
1 participant
You can’t perform that action at this time.