Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

assertion library "code" is not set by default / documentation is wrong #778

Closed
MLKiiwy opened this issue Oct 30, 2017 · 1 comment
Assignees
Labels
Milestone

Comments

@MLKiiwy
Copy link

@MLKiiwy MLKiiwy commented Oct 30, 2017

The current documenation says : "By default the assertion library code"

If you check the code :

The assert options is null by default, that mean no assertion lib is added by default. So all the examples in the readme fails because you need to specify the assertion lib with "lab -a code" (+ install it because code is a devDependency in this package).

Two options to fix it : change the doc, or change the code

@Marsup

This comment has been minimized.

Copy link
Member

@Marsup Marsup commented Oct 30, 2017

This is a breaking change in lab 15, documentation needs to be updated. If anyone wants to do it before Wyatt gets to it... ;)

@geek geek self-assigned this Oct 30, 2017
@geek geek added this to the 15.1.2 milestone Oct 30, 2017
@geek geek closed this in #779 Oct 30, 2017
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
3 participants
You can’t perform that action at this time.