Permalink
Browse files

I think I broke something

  • Loading branch information...
1 parent ce727fc commit 1c11302a6d3f31473920b0bd525ac2b7e58e7e44 @harleypig committed Dec 10, 2010
View
@@ -0,0 +1,2 @@
+.build
+Pod-Weaver-PluginBundle-AYOUNG-*
View
@@ -0,0 +1,24 @@
+$VAR1 = [
+ {
+ 'Perl::Critic::Policy::Modules::RequireFilenameMatchesPackage' => 0,
+ 'Perl::Critic::Policy::BuiltinFunctions::RequireGlobFunction' => 0,
+ 'Perl::Critic::Policy::Subroutines::ProhibitSubroutinePrototypes' => 0,
+ 'Perl::Critic::Policy::Modules::ProhibitEvilModules' => 0,
+ 'Perl::Critic::Policy::Variables::RequireLexicalLoopIterators' => 0,
+ 'Perl::Critic::Policy::Modules::RequireBarewordIncludes' => 0,
+ 'Perl::Critic::Policy::InputOutput::ProhibitBarewordFileHandles' => 0,
+ 'Perl::Critic::Policy::InputOutput::ProhibitTwoArgOpen' => 0,
+ 'Perl::Critic::Policy::ValuesAndExpressions::ProhibitLeadingZeros' => 0,
+ 'Perl::Critic::Policy::TestingAndDebugging::ProhibitNoStrict' => 0,
+ 'Perl::Critic::Policy::BuiltinFunctions::ProhibitSleepViaSelect' => 0,
+ 'Perl::Critic::Policy::BuiltinFunctions::ProhibitStringyEval' => 0,
+ 'Perl::Critic::Policy::ClassHierarchies::ProhibitOneArgBless' => 0,
+ 'Perl::Critic::Policy::InputOutput::ProhibitInteractiveTest' => 0,
+ 'Perl::Critic::Policy::Subroutines::ProhibitNestedSubs' => 0,
+ 'Perl::Critic::Policy::Subroutines::ProhibitReturnSort' => 0,
+ 'Perl::Critic::Policy::TestingAndDebugging::RequireUseStrict' => 0,
+ 'Perl::Critic::Policy::ControlStructures::ProhibitMutatingListFunctions' => 0,
+ 'Perl::Critic::Policy::Subroutines::ProhibitExplicitReturnUndef' => 0,
+ 'Perl::Critic::Policy::Variables::ProhibitConditionalDeclarations' => 0
+ }
+ ];
View
@@ -1,45 +0,0 @@
-
-use strict;
-use warnings;
-
-use Module::Build 0.3601;
-
-
-my %module_build_args = (
- 'build_requires' => {
- 'Carp' => '0',
- 'English' => '0',
- 'File::Find' => '0',
- 'File::Temp' => '0',
- 'Module::Build' => '0.3601',
- 'Path::Class' => '0',
- 'Scalar::Util' => '0',
- 'Test::More' => '0.94',
- 'Test::Perl::Critic::Progressive' => '0',
- 'Try::Tiny' => '0',
- 'perl' => '5.004'
- },
- 'configure_requires' => {
- 'ExtUtils::MakeMaker' => '6.31',
- 'Module::Build' => '0.3601'
- },
- 'dist_abstract' => 'AYOUNG\'s default Pod::Weaver config',
- 'dist_author' => [
- 'Alan Young <harleypig@gmail.com>'
- ],
- 'dist_name' => 'Pod-Weaver-PluginBundle-AYOUNG',
- 'dist_version' => '0.07',
- 'license' => 'perl',
- 'module_name' => 'Pod::Weaver::PluginBundle::AYOUNG',
- 'recommends' => {},
- 'recursive_test_files' => 1,
- 'requires' => {
- 'Pod::Weaver::Config::Assembler' => '0'
- },
- 'script_files' => []
-);
-
-
-my $build = Module::Build->new(%module_build_args);
-
-$build->create_build_script;
View
51 CHANGES
@@ -1,51 +0,0 @@
-Revision History for Pod-Weaver-PluginBundle-AYOUNG
-===================================================
-
-v0.06 2010-12-09
-----------------
-
-commit 2edac0be405dedabc4afb01ab1fd6a2a21316d96
-Author: Harley Pig <harleypig@gmail.com>
-
- keep testing
-
-v0.05 2010-12-09
-----------------
-
-commit 7285b010040444a3a47f97499f88866da60cb999
-Author: Harley Pig <harleypig@gmail.com>
-
- mindless committment
-
-v0.04 2010-12-09
-----------------
-
-commit 551bab9028c155c64bcb60ccbd8abfe4378750c8
-Author: Harley Pig <harleypig@gmail.com>
-
- more changes to dist.ini
-
-v0.03 2010-12-09
-----------------
-
-commit 27adadde7503822df8b0c961509b063bd2009b22
-Author: Harley Pig <harleypig@gmail.com>
-
- added/updated admin files
-
-commit eaa7ef74969e1cdc1c7b7cf76c1d14b0f8d7aa91
-Author: Harley Pig <harleypig@gmail.com>
-
- added/updated admin files
-
-v0.02 2010-12-09
-----------------
-
-commit 0c46ba9373f87eca1e0e60ca70eae56978308bad
-Author: Harley Pig <harleypig@gmail.com>
-
- Get changes into git
-
-===================================
-End of changes in the last 365 days
-===================================
View
44 INSTALL
@@ -1,44 +0,0 @@
-
-This is the Perl distribution Pod-Weaver-PluginBundle-AYOUNG.
-
-Installing Pod-Weaver-PluginBundle-AYOUNG is straightforward.
-
-## Installation with cpanm
-
-If you have cpanm, you only need one line:
-
- % cpanm Pod::Weaver::PluginBundle::AYOUNG
-
-If you are installing into a system-wide directory, you may need to pass the
-"-S" flag to cpanm, which uses sudo to install the module:
-
- % cpanm -S Pod::Weaver::PluginBundle::AYOUNG
-
-## Installing with the CPAN shell
-
-Alternatively, if your CPAN shell is set up, you should just be able to do:
-
- % cpan Pod::Weaver::PluginBundle::AYOUNG
-
-## Manual installation
-
-As a last resort, you can manually install it. Download the tarball, untar it,
-then build it:
-
- % perl Build.PL
- % ./Build && ./Build test
-
-Then install it:
-
- % ./Build install
-
-If you are installing into a system-wide directory, you may need to run:
-
- % sudo ./Build install
-
-## Documentation
-
-Pod-Weaver-PluginBundle-AYOUNG documentation is available as POD.
-You can run perldoc from a shell to read the documentation:
-
- % perldoc Pod::Weaver::PluginBundle::AYOUNG
Oops, something went wrong.

0 comments on commit 1c11302

Please sign in to comment.