Wrong option is selected after removing an element and search in a multiple select #388

Closed
webcore-it opened this Issue Dec 8, 2011 · 10 comments

Projects

None yet

9 participants

@webcore-it

Hi!

First I want to thank you for this great tool!
I found a bug in the multiple select and did not see it in the bugtracker.

Try this at http://harvesthq.github.com/chosen/
1. Add the "Dallas Cowboys"
2. Add the "Washington Redskins"
3. Remove the "Washington Redskins" by clicking the x
4. Search for "w" and add the "Washington Redskins" again via a click
5. The "New York Giants" will be added.

Removing an element via click, searching (means reducing the shown options) any other and adding it via click gives me wrong results. Doing step 3 or 4 via keybord does work very well.

Thanks
Tom

@MarcosBL

Confirmed here

@WizardOfOgz

👍

This bug is still present is Version 0.9.11 and seems like a pretty major issue. I'll post anything I find when if I get a chance to look into it.

@nativeprod

+1

Great work by the way!

@pfiller

I believe this issue is fixed. Can anyone please confirm that this is still happening in the latest version of master?

(note: the tag has not been updated yet, so 0.9.12 may still have the problem ... pull from master)

@pfiller

Tag is updated to 0.9.13 and I still don't see the issue. Closing this.

@pfiller pfiller closed this Apr 20, 2013
@WizardOfOgz

@pfiller Looks like the issue is fixed. Many thanks!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment