Skip to content
e3c198d
Compare
Choose a tag to compare

BUGFIX

  • Removed the limit (previously set to 1000) on how many Import entries can be loaded

The Linux build requires appropriately Qt_5.14 or Qt_5.15 to be installed.

The Windows build with vs13 suffix(built with Visual Studio 2013) has no external dependencies.

The Windows build with vs17 suffix (built with Visual Studio 2017) requires Microsoft Visual C++ 2015 Redistributable Package.

Legacy build available!
The Windows build with vs10 suffix is built with Qt4 (legacy) - in contrast to the other builds that are with Qt5 (recommended). It is prepared for the purpose of backward compatibility with old versions of Windows (i.e. XP).

e3c198d
Compare
Choose a tag to compare

BUGFIX

  • Fixed invalid PDB GUID parsing ( Issue #40 )

The Linux build requires appropriately Qt_5.14 or Qt_5.15 to be installed.

The Windows build with vs13 suffix(built with Visual Studio 2013) has no external dependencies.

The Windows build with vs17 suffix (built with Visual Studio 2017) requires Microsoft Visual C++ 2015 Redistributable Package.

Legacy build available!
The Windows build with vs10 suffix is built with Qt4 (legacy) - in contrast to the other builds that are with Qt5 (recommended). It is prepared for the purpose of backward compatibility with old versions of Windows (i.e. XP).

e3c198d
Compare
Choose a tag to compare

BUGFIX

  • Fixed crashing on a PE with a malformed resource ( Issue #42 )
  • Fixed invalid PDB GUID parsing ( Issue #40 )

The Linux build requires appropriately Qt_5.14 or Qt_5.15 to be installed.

The Windows build with vs13 suffix(built with Visual Studio 2013) has no external dependencies.

The Windows build with vs17 suffix (built with Visual Studio 2017) requires Microsoft Visual C++ 2015 Redistributable Package.

Legacy build available!
The Windows build with vs10 suffix is built with Qt4 (legacy) - in contrast to the other builds that are with Qt5 (recommended). It is prepared for the purpose of backward compatibility with old versions of Windows (i.e. XP).

e960c6f
Compare
Choose a tag to compare

FEATURE

  • Open a new instance from the menu (Issue #37)
  • Detect when the file in disk has changed and ask the user to reload it (Issue #38)
  • Allow to load multiple PEs at the time, using the dialog or the commandline (Issue #39 )

The Linux build requires appropriately Qt_5.14 or Qt_5.15 to be installed.

The Windows build with vs13 suffix(built with Visual Studio 2013) has no external dependencies.

The Windows build with vs17 suffix (built with Visual Studio 2017) requires Microsoft Visual C++ 2015 Redistributable Package.

Legacy build available!
The Windows build with vs10 suffix is built with Qt4 (legacy) - in contrast to the other builds that are with Qt5 (recommended). It is prepared for the purpose of backward compatibility with old versions of Windows (i.e. XP).

72ccedf
Compare
Choose a tag to compare

BUGFIX

  • Fixed calculation of DOS stub size ( #33 )
  • Fixed parsing of Load Config Directory (new variants)

FEATURE

  • Added parsing of .NET header
  • Added preview of icons and bitmaps in Resources
  • Added hints explaining the meaning of sections flags

The Linux build requires appropriately Qt_5.12 or Qt_5.14 to be installed.

The Windows build with vs13 suffix(built with Visual Studio 2013) has no external dependencies.

The Windows build with vs17 suffix (built with Visual Studio 2017) requires Microsoft Visual C++ 2015 Redistributable Package.

Legacy build available!
The Windows build with vs10 suffix is built with Qt4 (legacy) - in contrast to the other builds that are with Qt5 (recommended). It is prepared for the purpose of backward compatibility with old versions of Windows (i.e. XP).


Preview:

pebear_linux1

72ccedf
Compare
Choose a tag to compare

BUGFIX

  • Fixed bug in conversions of addresses before the first section. Display Bound Import Table.
  • Fixed glitch in displaying the "invalid" address marker (Issue #31)

FEATURE

  • improvements in the dark mode (i.e. changed the menu color)

REFACT

  • internal refactoring

The Linux build requires Qt_5.12 to be installed.

The Windows build with vs13 suffix(built with Visual Studio 2013) has no external dependencies.

The Windows build with vs17 suffix (built with Visual Studio 2017) requires Microsoft Visual C++ 2015 Redistributable Package.

Legacy build available!
The Windows build with vs10 suffix is built with Qt4 (legacy) - in contrast to the other builds that are with Qt5 (recommended). It is prepared for the purpose of backward compatibility with old versions of Windows (i.e. XP).

31fcf59
Compare
Choose a tag to compare

PE-bear 0.5.3.1 [Qt5]

BUGFIX

  • In dark mode: improved readability of some components, more polished look

The Linux build requires Qt_5.12 to be installed.

The Windows build with vs13 suffix(built with Visual Studio 2013) has no external dependencies.

The Windows build with vs17 suffix(built with Visual Studio 2017) requires Microsoft Visual C++ 2015 Redistributable Package.

31fcf59
Compare
Choose a tag to compare

PE-bear 0.5.3 [Qt5]

BUGFIX

  • Fixed parsing of GuardCFFunctionTable with metadata (Issue #11)
  • Added the missing .NET entry in Data Directory (Issue #30)

FEATURE

  • Added dark theme

The Linux build requires Qt_5.12 to be installed.

The Windows build with vs13 suffix(built with Visual Studio 2013) has no external dependencies.

The Windows build with vs17 suffix(built with Visual Studio 2017) requires Microsoft Visual C++ 2015 Redistributable Package.

31fcf59
Compare
Choose a tag to compare

PE-bear 0.5.2.3 [Qt5]

BUGFIX

  • Fixed adjusting sizes on the scaled screens (Issue #22)
  • Fixed error in bearparser: converting offsets before the first section (Issue hasherezade/bearparser#11)

FEATURE

  • Added SHA256 hash to the "General" panel

The Linux build requires Qt_5.12 to be installed.

The Windows build with vs13 suffix(built with Visual Studio 2013) has no external dependencies.

The Windows build with vs17 suffix(built with Visual Studio 2017) requires Microsoft Visual C++ 2015 Redistributable Package.

31fcf59
Compare
Choose a tag to compare

PE-bear 0.5.2.2 [Qt5]

BUGFIX

  • Fixed retrieving the default global font (workaround for the related bug in Qt)

FEATURE

  • Changes in fonts are now persistent
  • Added Zoom menu

The Linux build requires Qt_5.12 to be installed.

The Windows build with vs13 suffix(built with Visual Studio 2013) has no external dependencies.

The Windows build with vs17 suffix(built with Visual Studio 2017) requires Microsoft Visual C++ 2015 Redistributable Package.