New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

VMware not respecting gui = false unless it is the last box in multi-machine setup #5373

Closed
blomma opened this Issue Feb 21, 2015 · 1 comment

Comments

Projects
None yet
2 participants
@blomma

blomma commented Feb 21, 2015

Vagrant 1.7.2
VMware Fusion plugin 3.2.3

If you have a multi-machine setup and one of the machines has .gui = false set, the only way for vmware to respect that is to make sure that that box is the last to be brought up.
If there is a box with .gui = true after you have brought up a box with .gui = false then upon bringing that box up it will not only open a window for that box but also for the box with .gui = false.

@mitchellh

This comment has been minimized.

Show comment
Hide comment
@mitchellh

mitchellh Jul 9, 2015

Member

This is how VMware itself works. We ask it to not use a GUI, but it does if the GUI itself is already open. This is a VMware bug. Sorry!

Member

mitchellh commented Jul 9, 2015

This is how VMware itself works. We ask it to not use a GUI, but it does if the GUI itself is already open. This is a VMware bug. Sorry!

@mitchellh mitchellh closed this Jul 9, 2015

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment