Typo in SMB folder sync code #8404

Closed
mcuma opened this Issue Mar 23, 2017 · 4 comments

Comments

Projects
None yet
5 participants
@mcuma

mcuma commented Mar 23, 2017

Looks like I discovered a typo in the code that does SMB mount to sync folders between Windows host and Linux guest.

Vagrant version

Vagrant 1.9.3

Host operating system

Windows 10

Guest operating system

Ubuntu 14.04

I'll save everyone going through all the other details, since the issue is quite simple.

In file
C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-1.9.3/plugins/guests/linux/cap/mount_smb_shared_folder.rb
there is a typo on line 18.

Instead of
detected_ids = detect_owner_group_ids(machine, guest_path, mount_options, options)
should be
detected_ids = detect_owner_group_ids(machine, guestpath, mount_options, options)

After making the simple change, the SMB mount works. Before it, it was complaining that "guest_path" is missing.

Best,
MC

@Ratman9000

This comment has been minimized.

Show comment
Hide comment
@Ratman9000

Ratman9000 Mar 24, 2017

Wow so funny, I was suffering from this yesterday, and then started looking into it this morning and discovered the same bug. I logged back in tonight to submit a pull request for the fix, and saw this issue created on the same day. We must have been on the same wavelength today :) 👍

Ratman9000 commented Mar 24, 2017

Wow so funny, I was suffering from this yesterday, and then started looking into it this morning and discovered the same bug. I logged back in tonight to submit a pull request for the fix, and saw this issue created on the same day. We must have been on the same wavelength today :) 👍

@theocodes

This comment has been minimized.

Show comment
Hide comment
@theocodes

theocodes Apr 4, 2017

This is blocking me.. I run vagrant on windows 10 with vmware_workstation and smb for shared and so unfortunately can't use master as it needs to run in the installer..

Realistic speak, how long until this fix gets pushed to distribution and I can download it from https://www.vagrantup.com/downloads.html ?

thanks

This is blocking me.. I run vagrant on windows 10 with vmware_workstation and smb for shared and so unfortunately can't use master as it needs to run in the installer..

Realistic speak, how long until this fix gets pushed to distribution and I can download it from https://www.vagrantup.com/downloads.html ?

thanks

@martixy

This comment has been minimized.

Show comment
Hide comment
@martixy

martixy Apr 4, 2017

@theocodes You can simply fix the typo. It worked for me on W10.

martixy commented Apr 4, 2017

@theocodes You can simply fix the typo. It worked for me on W10.

@theocodes

This comment has been minimized.

Show comment
Hide comment
@theocodes

theocodes Apr 4, 2017

@martixy I had't realised the filed was in /embedded.. Thanks!

@martixy I had't realised the filed was in /embedded.. Thanks!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment