'cabal haddock' picks old package versions to generate the index #1051

Closed
feuerbach opened this Issue Sep 30, 2012 · 3 comments

Comments

Projects
None yet
2 participants
Contributor

feuerbach commented Sep 30, 2012

When cabal haddock regenerates the package index at ~/.cabal/share/doc/index.html, it picks the oldest version of every package instead of the newest one.

cabal-install version 0.14.0
using version 1.14.0 of the Cabal library
GHC 7.6.1

Member

23Skidoo commented Nov 24, 2012

This appears to be fixed in current master (tested by running cabal install syb-0.3.6.2 && cabal install syb-0.3.7). I can reproduce this with cabal-install 0.14, however.

The relevant commit seems to be 6192dbf.

@feuerbach Can you confirm that this is fixed?

Contributor

feuerbach commented Nov 25, 2012

Ah, yes, it seems to be fixed indeed. Thanks!

23Skidoo closed this Nov 25, 2012

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment