Add a configure check for whether GHC supports -threaded #1131

Open
23Skidoo opened this Issue Nov 23, 2012 · 2 comments

Comments

Projects
None yet
2 participants
Member

23Skidoo commented Nov 23, 2012

Apparently, GHC on ARM doesn't support -threaded, which makes it impossible to build cabal-install without editing the source by hand (see #1129). We should add a configure check for whether -threaded is supported.

23Skidoo was assigned Nov 23, 2012

Member

23Skidoo commented Nov 23, 2012

See #1132.

Member

23Skidoo commented Nov 26, 2012

We decided to do this for now:

if !arch(arm)
  ghc-options: -threaded

I'm leaving this ticket open: in the future we may want to detect whether the target supports -threaded automatically.

ttuegel added this to the _|_ milestone Apr 23, 2015

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment