Skip to content


Subversion checkout URL

You can clone with
Download ZIP


--reinstall being ignored for --only-dependencies #1175

nh2 opened this Issue · 4 comments

3 participants


I get the following with cabal-install-

$ cabal install --only-dependencies --reinstall

Resolving dependencies...
All the requested packages are already installed:
Use --reinstall if you want to reinstall anyway.

Appending more --reinstalls does not help.


Are you running it in some project's directory?


@dcoutts, is this the same issue as #870?


@23Skidoo Yes. Would there be a use for --only-dependencies if there was not a cabal file around that specifies dependencies?


If this behaviour is wanted as hinted at in #870, the error message is definitely confusing - telling me to append a flag that I did append, suggesting that that will change something.

I understand @dcoutts argument from over there that a proper "reinstall" would also require a base reinstall, but I usually use this to reinstall missing things like profiling or -dyn which are provided by base so I don't need to reinstall that one.

@ttuegel ttuegel added this to the _|_ milestone
@ttuegel ttuegel modified the milestone: cabal-install-1.24, _|_
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.