Incorrect ordering of versions #1181

Closed
nikita-volkov opened this Issue Jan 13, 2013 · 1 comment

Comments

Projects
None yet
2 participants

Typing cabal install bytestring installs bytestring-0.10.0.1 instead of the latest bytestring-0.10.2.0. And in general it treats the older 0.10.0.1 version as an upgrade even when the 0.10.2.0 version is installed forcefully with cabal install bytestring-0.10.2.0

Member

byorgey commented Jan 17, 2013

This is because the bytestring package has a global "preferred version" set as < 0.10.2. Presumably bytestring-0.10.2 is experimental, or does not work well with a large number of packages, though I do not know the actual reason.

byorgey closed this Jan 17, 2013

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment