cabal-install ./bootstrap.sh has incorrect Cabal version #1473

Closed
thoughtpolice opened this Issue Sep 4, 2013 · 1 comment

Comments

Projects
None yet
2 participants
Member

thoughtpolice commented Sep 4, 2013

Given the very new (and very awesome) cabal-install-1.18.0, when attempting to run ./bootstrap.sh, we see this:

a$ ./bootstrap.sh 
Checking installed packages for ghc-7.6.3...
Cabal-1.18.0.0 will be downloaded and installed.
transformers-0.3.0.0 will be downloaded and installed.
mtl-2.1.2 will be downloaded and installed.
deepseq is already installed and the version is ok.
text-0.11.3.1 will be downloaded and installed.
parsec-3.1.3 will be downloaded and installed.
network-2.4.1.2 will be downloaded and installed.
time is already installed and the version is ok.
HTTP-4000.2.8 will be downloaded and installed.
zlib-0.5.4.1 will be downloaded and installed.
random-1.0.1.1 will be downloaded and installed.
stm-2.4.2 will be downloaded and installed.

Downloading Cabal-1.18.0.0...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
curl: (22) The requested URL returned error: 404

Error during cabal-install bootstrap:
Failed to download Cabal.

Because it's looking for Cabal-1.18.0.0, not just Cabal-1.18.0. This can be fixed by changing the Cabal version constraint in bootstrap.sh to look for just Cabal-1.18.0 instead.

@23Skidoo 23Skidoo closed this in 03d12e6 Sep 5, 2013

Member

23Skidoo commented Sep 5, 2013

Fixed, thanks!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment