Apparently spurious error about Cabal-version check #1666

Open
rrnewton opened this Issue Feb 3, 2014 · 8 comments

Comments

Projects
None yet
7 participants
@rrnewton
Member

rrnewton commented Feb 3, 2014

To avoid issue #1284, I recently added an explicit requirement to my .cabal file that insists upon cabal 1.18 or newer:

Cabal-version:       >=1.18

But this seems to result in failures, as in this log here, which complains about >=1.18 not being available:

cabal: Error: some packages failed to install:
atomic-primops-0.5.99 failed during the configure step. The exception was:
user error (The package 'atomic-primops' requires Cabal library version -any
&& >=1.18 but no suitable version is installed.)

In spite of the fact that earlier in that same log, cabal --version reports:

cabal-install version 1.18.0.1
using version 1.18.0 of the Cabal library

Well then!

@rrnewton

This comment has been minimized.

Show comment Hide comment
@rrnewton

rrnewton Feb 3, 2014

Member

I reinstalled the latest released cabal (1.18.0.1 / 1.18.1.2) and saw the same behavior.

I also checked out HEAD just now (ccab03a / 1.19.2) and saw the same behavior there as well.

Member

rrnewton commented Feb 3, 2014

I reinstalled the latest released cabal (1.18.0.1 / 1.18.1.2) and saw the same behavior.

I also checked out HEAD just now (ccab03a / 1.19.2) and saw the same behavior there as well.

@cartazio cartazio referenced this issue in bscarlet/llvm-general Feb 3, 2014

Closed

odd error message when building with ghc 7.8 #82

@23Skidoo

This comment has been minimized.

Show comment Hide comment
@23Skidoo

23Skidoo Feb 3, 2014

Member

Thanks for the bug report. I'll look into this.

Member

23Skidoo commented Feb 3, 2014

Thanks for the bug report. I'll look into this.

@23Skidoo 23Skidoo self-assigned this Feb 3, 2014

@acfoltzer

This comment has been minimized.

Show comment Hide comment
@acfoltzer

acfoltzer Apr 28, 2014

Collaborator

I've been getting reports of folks seeing this when trying to build https://github.com/GaloisInc/cryptol. It seems to arise when Cabal the library doesn't end up in one of their ghc-pkg databases for whatever reason. This is common when folks install binaries from package managers, for example.

A temporary fix that seems to work is to add Cabal to the build-depends of the package in question, but this seems like an odd way to go about it.

Collaborator

acfoltzer commented Apr 28, 2014

I've been getting reports of folks seeing this when trying to build https://github.com/GaloisInc/cryptol. It seems to arise when Cabal the library doesn't end up in one of their ghc-pkg databases for whatever reason. This is common when folks install binaries from package managers, for example.

A temporary fix that seems to work is to add Cabal to the build-depends of the package in question, but this seems like an odd way to go about it.

@23Skidoo

This comment has been minimized.

Show comment Hide comment
@23Skidoo

23Skidoo Apr 28, 2014

Member

I guess the solver could add that dependency automatically.

Member

23Skidoo commented Apr 28, 2014

I guess the solver could add that dependency automatically.

@rrnewton

This comment has been minimized.

Show comment Hide comment
@rrnewton

rrnewton Apr 28, 2014

Member

Thanks for the tip Adam. I think I did end up adding Cabal.

Member

rrnewton commented Apr 28, 2014

Thanks for the tip Adam. I think I did end up adding Cabal.

@nh2

This comment has been minimized.

Show comment Hide comment
@nh2

nh2 Oct 14, 2014

Member

I got this in TravisCI, for dependencies that I have no control of:

cabal: Error: some packages failed to install:
cairo-0.13.0.3 failed during the configure step. The exception was:
user error (The package 'cairo' requires Cabal library version -any && >=1.18
but no suitable version is installed.)
gio-0.13.0.1 depends on glib-0.13.0.4 which failed to install.
glib-0.13.0.4 failed during the configure step. The exception was:
user error (The package 'glib' requires Cabal library version -any && >=1.18
but no suitable version is installed.)
gtk-0.13.0.2 depends on glib-0.13.0.4 which failed to install.
pango-0.13.0.2 depends on glib-0.13.0.4 which failed to install.
svgcairo-0.13.0.0 depends on glib-0.13.0.4 which failed to install.
Member

nh2 commented Oct 14, 2014

I got this in TravisCI, for dependencies that I have no control of:

cabal: Error: some packages failed to install:
cairo-0.13.0.3 failed during the configure step. The exception was:
user error (The package 'cairo' requires Cabal library version -any && >=1.18
but no suitable version is installed.)
gio-0.13.0.1 depends on glib-0.13.0.4 which failed to install.
glib-0.13.0.4 failed during the configure step. The exception was:
user error (The package 'glib' requires Cabal library version -any && >=1.18
but no suitable version is installed.)
gtk-0.13.0.2 depends on glib-0.13.0.4 which failed to install.
pango-0.13.0.2 depends on glib-0.13.0.4 which failed to install.
svgcairo-0.13.0.0 depends on glib-0.13.0.4 which failed to install.
@sinelaw-ci

This comment has been minimized.

Show comment Hide comment
@sinelaw-ci

sinelaw-ci Oct 27, 2014

any news? I have the same problem as @nh2

any news? I have the same problem as @nh2

sinelaw-ci added a commit to sinelaw-ci/xml-to-json that referenced this issue Oct 27, 2014

@23Skidoo

This comment has been minimized.

Show comment Hide comment
@23Skidoo

23Skidoo Oct 27, 2014

Member

For now, the workaround is to add a line cabal install Cabal to your Travis script. Packages with build-type: Custom require the appropriate version of the Cabal library to be installed.

Member

23Skidoo commented Oct 27, 2014

For now, the workaround is to add a line cabal install Cabal to your Travis script. Packages with build-type: Custom require the appropriate version of the Cabal library to be installed.

bergey added a commit to diagrams/diagrams-cairo that referenced this issue Dec 17, 2014

@ttuegel ttuegel modified the milestones: cabal-install-1.24, cabal-install-1.22 Apr 23, 2015

@ttuegel ttuegel added the type: bug label Apr 23, 2015

@RyanGlScott RyanGlScott referenced this issue in ekmett/semigroupoids Jun 2, 2015

Merged

Fix GHC 7.0 build #33

@23Skidoo 23Skidoo modified the milestones: cabal-install 1.24, cabal-install 1.26 Feb 21, 2016

@23Skidoo 23Skidoo removed their assignment Jul 27, 2016

@ezyang ezyang modified the milestone: cabal-install 2.0 Sep 6, 2016

ocheron added a commit to ocheron/hs-certificate that referenced this issue Mar 4, 2017

Fix Travis build with cryptonite-0.22
The new cryptonite release contains Cabal-Version >=1.18 which caused
PR #83 build to fail when GHC is bundled with an older Cabal library
version.

Trying to apply the solution found in haskell/cabal#1666 but that will
make the build slower.

Melvar added a commit to Melvar/Idris-dev that referenced this issue Mar 23, 2017

Make Travis manually install the Cabal library
to make sure it is available in a suitable version. Works around
haskell/cabal#1666

byorgey added a commit to diagrams/diagrams-lib that referenced this issue May 28, 2017

travis: add Cabal to EXTRA_DEPS_PRE
We were getting build failures for GHC 7.6.3 which seem to be related
to haskell/cabal#1666 .

feuerbach added a commit to feuerbach/regex-applicative that referenced this issue Dec 25, 2017

Update travis configurations
Require cabal-2.0 so that we can build js-jquery, a dependency of
criterion.
(cabal-1.18 doesn't do the job; see
haskell/cabal#1666)
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment