Installing cabal-install 0.4.0: dependencies problem with zlib #274

Closed
bos opened this Issue May 24, 2012 · 1 comment

Comments

Projects
None yet
1 participant
Contributor

bos commented May 24, 2012

(Imported from Trac #281, reported by guest on 2008-05-15)

cabal-install package 0.4.0 from hackage wants zlib (>=0.3)

Ok, zlib-0.4.0.4 from hackage installed:

% ghc-pkg list | grep zlib
    Yampa-0.9.2, frag-1.1, zlib-0.4.0.4
But:
% runhaskell Setup.lhs configure -v3
Configuring cabal-install-0.4.0...
Creating dist (and its parents)
/usr/bin/ghc --numeric-version
looking for package tool: ghc-pkg near compiler in /usr/bin
found package tool in /usr/bin/ghc-pkg
/usr/bin/ghc-pkg --version
/usr/bin/ghc -c /tmp/tmp27993.c -o /tmp/tmp27993.o
/usr/bin/ld -x -r /tmp/tmp27993.o -o /tmp/tmp27994.o
/usr/bin/ghc --supported-languages
Reading installed packages...
/usr/bin/ghc-pkg --global list
Setup.lhs: At least the following dependencies are missing:
    zlib >=0.3
Contributor

bos commented May 24, 2012

(Imported comment by @dcoutts on 2008-05-15)

You want:

runhaskell Setup.lhs configure --user
The rationale was that by default package installs are global so the prefix defaults to /usr/local and we only look at the global package db. Of course if we are doing a global install then it is vital that we do not depend on packages from the per-user package database because they'd not be available once we'd installed globally.

We do acknowledge that the global default is actually a bit of a pain. So for the cabal-install interface we default to per-user installs.

I would also recommend that you use the latest version of cabal-install rather than the rather old version that's available on hackage.

http://hackage.haskell.org/trac/hackage/wiki/CabalInstall

(It needs the development version of Cabal which is why it cannot yet be released on hackage)

@bos bos closed this May 24, 2012

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment