Skip to content

make cabal --cabal-lib-version="" take a dependency or a specific number #390

Closed
bos opened this Issue May 24, 2012 · 2 comments

3 participants

@bos
Haskell member
bos commented May 24, 2012

(Imported from Trac #397, reported by @dcoutts on 2008-11-08)

The --cabal-lib-version= flag currently takes a specific version number. It could easily be like --constraint= or like cabal install "foo < 2" and take a dependency or a specific version number.

@bos
Haskell member
bos commented May 24, 2012

(Imported comment by @kosmikus on 2008-11-08)

I just tried to figure out how this flag behaves now in practice, and it seems I can specify any version as --cabal-lib-version and I don't get any error message. Ranges still don't seem to be supported.

@BardurArantsson

Obsolete (last comment 2008.). Please close.

@23Skidoo 23Skidoo closed this Jun 26, 2015
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.