cabal-install depends on time library 1.1.*, whereas 1.2 is default #734

Closed
bos opened this Issue May 24, 2012 · 1 comment

Comments

Projects
None yet
1 participant
Contributor

bos commented May 24, 2012

(Imported from Trac #744, reported by guest on 2010-09-26)

Building cabal-install worked fine for me with the latest version of the time library: 1.2.0.3.

I suggest removing the requirement '&& < 1.2' for the time library in cabal-install.cabal.

Contributor

bos commented May 24, 2012

(Imported comment by @benmachine on 2010-09-26)

cabal-install.cabal now reads:

                   time     >= 1.1      && < 1.3
so I assume this is fixed. It would be a good idea to keep an eye on these things for future releases but I suppose we can make a separate ticket for those if/when they arise.

@bos bos closed this May 24, 2012

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment