Skip to content

cabal install cabal-install-0.10.2 fails due to dependencies #896

Closed
bos opened this Issue May 24, 2012 · 1 comment

1 participant

@bos
Haskell member
bos commented May 24, 2012

(Imported from Trac #906, reported by @andreasvoellmy on 2011-12-15)

cabal install cabal-install-0.10.2 fails for me. The problem is that it depends on unix < 2.5 and versions of unix before 2.5 depend on base < 4.4. But base 4.4 is selected very early on in the cabal install. Later versions of unix (i.e. 2.5.0.0) work with base < 4.5, so it seems like this issue could be fixed by releasing a new version of cabal-install that works with unix 2.5.

Here is the output from cabal install cabal-install-0.10.2 -v3 --dry-run:

searching for ghc in path.
found ghc at /usr/local/bin/ghc
("/usr/local/bin/ghc",["--numeric-version"])
/usr/local/bin/ghc is version 7.2.1
looking for package tool: ghc-pkg near compiler in /usr/local/bin
found package tool in /usr/local/bin/ghc-pkg
("/usr/local/bin/ghc-pkg",["--version"])
/usr/local/bin/ghc-pkg is version 7.2.1
("/usr/local/bin/ghc",["--supported-languages"])
Reading installed packages...
("/usr/local/bin/ghc-pkg",["dump","--global","-v2"])
("/usr/local/bin/ghc-pkg",["dump","--user","-v2"])
("/usr/local/bin/ghc",["--print-libdir"])
Reading available packages...
Resolving dependencies...
selecting cabal-install-0.10.2 (hackage) and discarding Cabal-1.1.6, 1.2.1,
1.2.2.0, 1.2.3.0, 1.2.4.0, 1.4.0.0, 1.4.0.1, 1.4.0.2, 1.6.0.1, 1.6.0.2,
1.6.0.3, 1.8.0.2, 1.8.0.4, 1.8.0.6, 1.10.0.0, 1.12.0, HTTP-3000.0.0, 3001.0.0,
3001.0.1, 3001.0.2, 3001.0.3, 3001.0.4, 3001.1.3, 3001.1.4, 3001.1.5,
4000.0.0, 4000.0.1, pretty-1.1.0.0, process-1.1.0.0, time-1.0, 1.3,
unix-2.5.0.0, zlib-0.2 and 0.3
selecting base-4.4.0.0 (installed)
selecting ffi-1.0 (installed)
selecting ghc-prim-0.2.0.0 (installed)
selecting integer-gmp-0.3.0.0 (installed)
selecting rts-1.0 (installed)
selecting random-1.0.1.0 (installed or hackage) and discarding random-1.0.0.0,
1.0.0.1, 1.0.0.2 and 1.0.0.3
selecting time-1.2.0.5 (installed or hackage) and discarding time-1.1.2.0,
1.1.2.1, 1.1.2.2, 1.1.2.3, 1.1.2.4, 1.1.3, 1.1.4, 1.2, 1.2.0.1, 1.2.0.2,
1.2.0.3 and 1.2.0.4
selecting zlib-0.5.3.1 (hackage) and discarding zlib-0.4, 0.4.0.1, 0.4.0.2,
0.4.0.3, 0.4.0.4, 0.5.0.0 and 0.5.2.0
selecting HTTP-4000.1.2 (hackage) and discarding HTTP-4000.0.2, 4000.0.3,
4000.0.4, 4000.0.5, 4000.0.6, 4000.0.7, 4000.0.8, 4000.0.9, 4000.0.10,
4000.1.0 and 4000.1.1
selecting network-2.3.0.5 (hackage) and discarding network-2.0, 2.1.0.0,
2.2.0.0, 2.2.0.1, 2.2.1, 2.2.1.1, 2.2.1.2, 2.2.1.3, 2.2.1.4, 2.2.1.5, 2.2.1.6,
2.2.1.7, 2.2.1.8, 2.2.1.9, 2.2.1.10, 2.2.3, 2.2.3.1, 2.3, 2.3.0.1, 2.3.0.2,
2.3.0.3 and 2.3.0.4
selecting parsec-3.1.1 (hackage) and discarding parsec-2.0, 2.1.0.0, 2.1.0.1,
3.0.0, 3.0.1 and 3.1.0
selecting bytestring-0.9.2.0 (installed or hackage) and discarding
bytestring-0.9, 0.9.0.1, 0.9.0.2, 0.9.0.3, 0.9.0.4, 0.9.1.0, 0.9.1.1, 0.9.1.2,
0.9.1.3, 0.9.1.4, 0.9.1.5, 0.9.1.6, 0.9.1.7, 0.9.1.8, 0.9.1.9 and 0.9.1.10
selecting mtl-2.0.1.0 (installed or hackage) and discarding mtl-1.0, 1.1.0.0,
1.1.0.1, 1.1.0.2, 1.1.1.0, 1.1.1.1, 2.0.0.0, transformers-0.0.0.0, 0.0.1.0,
0.1.0.0, 0.1.0.1, 0.1.1.0, 0.1.3.0 and 0.1.4.0
selecting transformers-0.2.2.0 (installed or hackage) and discarding
transformers-0.2.0.0 and 0.2.1.0
selecting Cabal-1.10.2.0 (hackage) and discarding Cabal-1.10.1.0
selecting process-1.0.1.5 (hackage) and discarding filepath-1.0,
process-1.0.0.0, 1.0.1.1, 1.0.1.2, 1.0.1.3 and 1.0.1.4
selecting pretty-1.0.1.2 (hackage) and discarding pretty-1.0.0.0, 1.0.1.0 and
1.0.1.1
selecting directory-1.1.0.1 (installed or hackage) and discarding
directory-1.0.0.0, 1.0.0.3, 1.0.1.0, 1.0.1.1, 1.0.1.2 and 1.1.0.0
selecting
cabal: cannot configure unix-2.4.2.0. It requires base >=4.2 && <4.4
For the dependency on base >=4.2 && <4.4 there are these packages:
base-4.2.0.0, base-4.2.0.1, base-4.2.0.2, base-4.3.0.0 and base-4.3.1.0.
However none of them are available.
base-4.2.0.0 was excluded because base-4.4.0.0 was selected instead
base-4.2.0.0 was excluded because of the top level dependency base -any
base-4.2.0.1 was excluded because base-4.4.0.0 was selected instead
base-4.2.0.1 was excluded because of the top level dependency base -any
base-4.2.0.2 was excluded because base-4.4.0.0 was selected instead
base-4.2.0.2 was excluded because of the top level dependency base -any
base-4.3.0.0 was excluded because base-4.4.0.0 was selected instead
base-4.3.0.0 was excluded because of the top level dependency base -any
base-4.3.1.0 was excluded because base-4.4.0.0 was selected instead
base-4.3.1.0 was excluded because of the top level dependency base -any
@bos
Haskell member
bos commented May 24, 2012

(Imported comment by @kosmikus on 2011-12-15)

Going to be fixed by the upcoming release.

@bos bos closed this May 24, 2012
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.