Skip to content

Having a problem with haskell load file C-c C-l. #257

Closed
mijoharas opened this Issue Apr 3, 2014 · 1 comment

2 participants

@mijoharas

So I have the same bug that is described here with a slightly different implementation. I have a prompt that is set by:

:set prompt "%s λ> "

which gives a prompt that looks like:

GHCi, version 7.6.3: http://www.haskell.org/ghc/  :? for help
Loading package ghc-prim ... linking ... done.
Loading package integer-gmp ... linking ... done.
Loading package base ... linking ... done.
Prelude λ> 

I fixed it by modifying your regexp from here
to this (adding an optional λ at the end of the first part before the >:

"^\\*?[[:upper:]][\\._[:alnum:]]*\\(?: \\*?[[:upper:]][\\._[:alnum:]]*\\)*\\( λ\\)?> \\|^λ?> $"

I'll send the pull request in a second.

@mijoharas mijoharas added a commit to mijoharas/haskell-mode that referenced this issue Apr 3, 2014
@mijoharas mijoharas Additional fix for ghci prompt inferior-haskell-mode
This is a fix for [this issue](haskell#257) which is conceptually the same as [this older issue](haskell#176)
632bb04
@chrisdone chrisdone added a commit that referenced this issue May 10, 2014
@mijoharas mijoharas Additional fix for ghci prompt inferior-haskell-mode
This is a fix for [this issue](#257) which is conceptually the same as [this older issue](#176)
23b385b
@chrisdone
Haskell member

Merged now.

@chrisdone chrisdone closed this May 10, 2014
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.