Permalink
Browse files

Merge commit '32e9ad874f7bd443fe9122fc9a1f8f6fb277e02e'

  • Loading branch information...
2 parents f8de314 + 32e9ad8 commit 14851636b1e5587e78820768a79a2e47ae673406 @mzero mzero committed May 28, 2013
Showing with 11 additions and 9 deletions.
  1. +1 −1 download-website/mac.markdown
  2. +4 −5 src/generic/tarball/README
  3. +6 −3 src/macos/README
@@ -17,7 +17,7 @@ Download the Mac OS X installer here:
<small>SHA-1: `89e6fb747816af69acabc5c04cee103257855614`</small>
<!--
-* <small>*Pick the 32-bit vesion, unless you have a specific reason to use the 64-bit version.*<br />
+* <small>*Pick the 32-bit version, unless you have a specific reason to use the 64-bit version.*<br />
The 32-bit one is slightly faster for most programs.<br />
If you use **MacPorts**, **brew**, or other 3rd party libraries, see below.</small>
-->
@@ -12,12 +12,11 @@ web site (see above URL) contains builds for Mac OS X and Windows that include
everything you need, including GHC.
The web site also contains links for those Linux distributions for which there
-is a pre-build version. In most cases, that version of the platform is availble
+is a pre-build version. In most cases, that version of the platform is available
through the normal package manager for the distribution, rather than directly
from the Haskell Platform web site.
-
Preparation
-----------
You will need to have GHC 7.6.3 installed prior to building the platform.
@@ -29,7 +28,6 @@ platform instead. If you've gotten this far, you can ignore that.
You can use a different version of GHC, but it may not work.
-
You will also need the developer packages for various standard system libraries,
such as zlib and GLUT. Exactly which packages you need will differ based on
the OS distribution you use. In general, if you get an error during the build
@@ -39,12 +37,13 @@ need both the library and the development package for the library.
Build and Install
-----------------
+
In this directory, run:
./configure
This is standard autoconf, so options like --prefix will work. Run with --help
-to see all the options. In particular, if you are using a different versino of
+to see all the options. In particular, if you are using a different version of
GHC, you'll need to add --enable-unsupported-ghc-version.
Now build the packages:
@@ -55,5 +54,5 @@ Finally, to install everything, use
make install
-Note that you will probably have to run this command 'sudo'.
+Note that you will probably have to run this command with 'sudo'.
View
@@ -10,7 +10,7 @@ To build the Haskell Platform for Mac OS X:
4a) If you have the proper GHC installer package:
create a subdirectory "dist-i386" or "dist-x86_64 here
move or sym-link the package into it
-You should have a file there named seomthing like
+You should have a file there named something like
GHC-7.6.3-i386.pkg
GHC-7.6.3-x86_64.pkg
Run
@@ -33,6 +33,7 @@ Run
6) Edit the ghc settings file in:
dist/root/Library/Frameworks/GHC.framework/Versions/7.4.1-i386/usr/lib/ghc-7.4.1
+
Make sure that the entries for "C compiler command" and "ar command" are:
("C compiler command", "/usr/bin/gcc"),
("ar command", "/usr/bin/ar"),
@@ -57,10 +58,12 @@ system. If things fail during this step, you'll probably have to remove
make doc
make polish
-10) Build the finall installer:
+10) Build the final installer:
make installer
This will ask you for your password so it can sudo the tree to root. Then it
-will launch PackageMaker.Now click Build... and choose a suitable name and location for the result.
+will launch PackageMaker. Now click Build... and choose a suitable name and
+location for the result.
11) Go have some tea.
+

0 comments on commit 1485163

Please sign in to comment.