Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

first take at 2012.2.0.0 package version list

  • Loading branch information...
commit 69ac2502f6557592f01e2ae2985d6d61b74097ce 1 parent 8663dd4
@mzero mzero authored
View
1  .gitignore
@@ -0,0 +1 @@
+src/macos/dist*
View
24 NOTES-2010.1.0.0
@@ -0,0 +1,24 @@
+= Release 2010.1.0 =
+
+Package changes:
+
+ # Added extensible-exceptions: don't list.
+ # Remove packedstring
+ # Time moves back into the base set.
+ # Not upgrading to parsec 3!
+ # Not adding OpenGL 2.4,
+ -- would add OpenGLRaw >=1.1.0.0, GLURaw >=1.1.0.0,
+ StateVar -any, ObjectName -any, Tensor -any
+ # Ship a newer haddock? No.
+ # Added deepseq to the HP.
+
+ # Due to ghc's dependency on Cabal, we can't upgrade Cabal as part of
+ the HP build.
+ + Bug in Cabal, meaning local package db's were dropped.
+ - work around: manually register.
+ + Bug in Cabal on Windows -- wait for 6.12.2
+
+ # New update to cabal-install coming.
+ # Policy: Modify script to include only --global packages in a global install,
+ and always include --user packages in user installs
+
View
69 NOTES-2012.2.0.0
@@ -0,0 +1,69 @@
+= Release 2012.2 =
+
+Outstanding issues
+ [] do we need to bump min cabal in haskell-platform.cabal
+ [] haskell2000 was not listed in core.packages
+ [] integer-gmp is in core.packages, but not in .cabal file
+ [] verify random is no longer in GHC, so we'll explicitly include
+ [] note non-standard version numbers for Cabal and time
+ [] verify: packages dist with bin GHC that are not part of HP:
+ bin-package-db, binary, ghc-prim, hoopl, integer-gmp
+ [] verify: hscolour is not part of HP
+ [] should deepseq be considered "core", as GHC supplies
+ [] alex was bumped to 3, good bad ugle?
+
+
+Version Changes
+ GHC 7.0.4 --> 7.4.1
+ -- core libraries, provided with GHC
+ array 0.3.0.2 --> 0.4.0.0
+ base 4.3.1.0 --> 4.5.0.0
+ bytestring 0.9.1.10 --> 0.9.2.1
+ Cabal 1.10.2.0 --> 1.14.0
+ containers 0.4.0.0 --> 0.4.2.1
+ directory 1.1.0.0 --> 1.1.0.2
+ extensible-exceptions 0.1.1.2 --> 0.1.1.4
+ filepath 1.2.0.0 --> 1.3.0.0
+ haskell2010 1.0.0.0 --> 1.1.0.1
+ haskell98 1.1.0.1 --> 2.0.0.1
+ hpc 0.5.0.6 --> 0.5.1.1
+ old-locale 1.0.0.2 --> 1.0.0.4
+ old-time 1.0.0.6 --> 1.1.0.0
+ pretty 1.0.1.2 --> 1.1.1.0
+ process 1.0.1.5 --> 1.1.0.1
+ template-haskell 2.5.0.0 --> 2.7.0.0
+ time 1.2.0.3 --> 1.4
+ unix 2.4.2.0 --> 2.5.1.0
+ Win32 2.2.0.1 --> 2.2.2.0
+ -- additional HP libraries
+ cgi 3001.1.7.4 --> 3001.1.7.4 (same)
+ deepseq 1.1.0.2 --> 1.3.0.0
+ fgl 5.4.2.4 --> 5.4.2.4 (same)
+ GLUT 2.1.2.1 --> 2.1.2.1 (same)
+ haskell-src 1.0.1.4 --> 1.0.1.5
+ html 1.0.1.2 --> 1.0.1.2 (same)
+ HTTP 4000.1.2 --> 4000.2.3
+ HUnit 1.2.4.2 --> 1.2.4.2 (same)
+ mtl 2.0.1.0 --> 2.1.1
+ network 2.3.0.5 --> 2.3.0.13
+ OpenGL 2.2.3.0 --> 2.2.3.1
+ parallel 3.1.0.1 --> 3.2.0.2
+ parsec 3.1.1 --> 3.1.2
+ QuickCheck 2.4.1.1 --> 2.4.2
+ random 1.0.0.3 --> 1.0.1.1
+ regex-base 0.93.2 --> 0.93.2 (same)
+ regex-compat 0.95.1 --> 0.95.1 (same)
+ regex-posix 0.95.1 --> 0.95.1 (same)
+ stm 2.2.0.1 --> 2.3
+ syb 0.3.3 --> 0.3.6.1
+ text 0.11.1.5 --> 0.11.2.0
+ transformers 0.2.2.0 --> 0.3.0.0
+ xhtml 3000.2.0.4 --> 3000.2.0.5
+ zlib 0.5.3.1 --> 0.5.3.3
+
+ -- tools
+ cabal-install 0.10.2 --> 0.14.0
+ alex 2.3.5 --> 3.0.1
+ happy 1.18.6 --> 1.18.9
+ haddock 2.9.2 --> 2.10.0 -- comes with GHC
+
View
54 RELEASE
@@ -1,7 +1,32 @@
+ [] Start a NOTES file for the release
- * update list of libraries shipped with GHC.
+ [] Update package versions
+ * Libraries shipped with GHC.
http://haskell.org/haskellwiki/Libraries_released_with_GHC
- * update list of external libraries to latest stable version.
+ -or-
+ from an expanded GHC source package
+ find . -name tests -prune -type f -o -name '*.cabal'
+ | xargs grep -i version: | grep -v -i cabal-version
+
+ [] update haskell-platform.cabal
+ [] update src/gneric/tarball/packages/core.packages
+
+ * External libraries to latest stable version
+ * set up to build macos, and run
+ make rewrap
+ * copy over haskell-platform.cabal to an empty directory
+ * remove all the version constraints on non-GHC packages
+ * uncomment all the version constraints on the GHC packages
+ * set as appropriate:
+ DIST=../hp-github/src/macos/dist-i386
+ * run
+ PATH=$DIST/bin:$PATH cabal instal \
+ --only-dependencies --upgrade-dependencies\
+ --package-db=$DIST/package.conf.d --dry-run
+ * this will solve for a consistent set of versions!
+
+ [] update haskell-platform.cabal
+
* check and follow up on changes to visible packages.
* check unix package builds
* tarball/packages/core.packages has to be updated from .cabal file
@@ -19,31 +44,6 @@
# publish reddit links with CDN.
------------------------------------------------------------------------
-= 2010.1.0 release =
-
-Package changes:
-
- # Added extensible-exceptions: don't list.
- # Remove packedstring
- # Time moves back into the base set.
- # Not upgrading to parsec 3!
- # Not adding OpenGL 2.4,
- -- would add OpenGLRaw >=1.1.0.0, GLURaw >=1.1.0.0,
- StateVar -any, ObjectName -any, Tensor -any
- # Ship a newer haddock? No.
- # Added deepseq to the HP.
-
- # Due to ghc's dependency on Cabal, we can't upgrade Cabal as part of
- the HP build.
- + Bug in Cabal, meaning local package db's were dropped.
- - work around: manually register.
- + Bug in Cabal on Windows -- wait for 6.12.2
-
- # New update to cabal-install coming.
- # Policy: Modify script to include only --global packages in a global install,
- and always include --user packages in user installs
-
-------------------------------------------------------------------------
= Site =
* Generate contents page inclusion.
View
84 haskell-platform.cabal
@@ -1,5 +1,5 @@
name: haskell-platform
-version: 2011.4.0.0
+version: 2012.2.0.0
homepage: http://haskell.org/platform
license: BSD3
license-file: LICENSE
@@ -23,68 +23,68 @@ description:
cabal-version: >= 1.8
build-type: Custom
-tested-with: GHC ==7.0.4
+tested-with: GHC ==7.4.1
library
build-depends:
-- ghc 7.x
-- Core libraries: provided by every ghc installation
-- We don't include "non-API" packages here.
- -- array ==0.3.0.2
- -- base ==4.3.1.0
- -- bytestring ==0.9.1.10
- -- Cabal ==1.10.2.0
- -- containers ==0.4.0.0
- -- directory ==1.1.0.0
- -- extensible-exceptions ==0.1.1.2
- -- filepath ==1.2.0.0
- -- haskell2010 ==1.0.0.0
- -- haskell98 ==1.1.0.1
- -- hpc ==0.5.0.6
- -- old-locale ==1.0.0.2
- -- old-time ==1.0.0.6
- -- pretty ==1.0.1.2
- -- process ==1.0.1.5
- -- random ==1.0.0.3
- -- template-haskell ==2.5.0.0
- -- time ==1.2.0.3
- -- unix ==XXX 2.4.2.0
- -- Win32 ==XXX 2.2.0.1
+ -- array ==0.4.0.0
+ -- base ==4.5.0.0
+ -- bytestring ==0.9.2.1
+ -- Cabal ==1.14.0
+ -- containers ==0.4.2.1
+ -- directory ==1.1.0.2
+ -- extensible-exceptions ==0.1.1.4
+ -- filepath ==1.3.0.0
+ -- haskell2010 ==1.1.0.1
+ -- haskell98 ==2.0.0.1
+ -- hpc ==0.5.1.1
+ -- old-locale ==1.0.0.4
+ -- old-time ==1.1.0.0
+ -- pretty ==1.1.1.0
+ -- process ==1.1.0.1
+ -- template-haskell ==2.7.0.0
+ -- time ==1.4
+ -- unix ==2.5.1.0
+ -- Win32 ==2.2.2.0
-- Libraries in addition to what GHC provides:
-- Note: newer versions of cgi need monad-catchio.
cgi ==3001.1.7.4,
+ deepseq ==1.3.0.0,
fgl ==5.4.2.4,
GLUT ==2.1.2.1,
- haskell-src ==1.0.1.4,
+ haskell-src ==1.0.1.5,
html ==1.0.1.2,
+ HTTP ==4000.2.3,
HUnit ==1.2.4.2,
- network ==2.3.0.5,
- OpenGL ==2.2.3.0,
- parallel ==3.1.0.1,
- parsec ==3.1.1,
- QuickCheck ==2.4.1.1,
+ mtl ==2.1.1
+ network ==2.3.0.13,
+ OpenGL ==2.2.3.1,
+ parallel ==3.2.0.2,
+ parsec ==3.1.2,
+ QuickCheck ==2.4.2,
+ random ==1.0.1.1,
regex-base ==0.93.2,
regex-compat ==0.95.1,
regex-posix ==0.95.1,
- stm ==2.2.0.1,
- syb ==0.3.3,
- xhtml ==3000.2.0.4,
- zlib ==0.5.3.1,
- HTTP ==4000.1.2,
- deepseq ==1.1.0.2,
+ stm ==2.3,
+ syb ==0.3.6.1,
+ text ==0.11.2.0,
+ transformers ==0.3.0.0,
+ xhtml ==3000.2.0.5,
+ zlib ==0.5.3.3,
-- 2011.1 proposals:
- text ==0.11.1.5,
- transformers ==0.2.2.0,
- mtl ==2.0.1.0
-- Depending on programs does not work, they are not registered
-- We list them to help distro packaging.
build-tools:
- cabal-install ==0.10.2,
- alex ==2.3.5,
- happy ==1.18.6
- -- hscolour ==1.17
- -- haddock ==2.9.2 -- need to use the one shipped with ghc
+ cabal-install ==0.14.0,
+ alex ==3.0.1,
+ happy ==1.18.9
+ -- hscolour ==1.19
+ -- haddock ==2.10.0 -- need to use the one shipped with ghc
View
37 src/generic/tarball/packages/core.packages
@@ -1,20 +1,21 @@
-array-0.3.0.2
-base-4.3.1.0
-bytestring-0.9.1.10
-Cabal-1.10.2.0
-containers-0.4.0.0
-directory-1.1.0.0
-extensible-exceptions-0.1.1.2
-filepath-1.2.0.0
+array-0.4.0.0
+base-4.5.0.0
+bytestring-0.9.2.1
+Cabal-1.14.0
+containers-0.4.2.1
+directory-1.1.0.2
+extensible-exceptions-0.1.1.4
+filepath-1.3.0.0
ghc-prim-0.2.0.0
-haskell98-1.1.0.1
-hpc-0.5.0.6
-integer-gmp-0.2.0.3
-old-locale-1.0.0.2
-old-time-1.0.0.6
-pretty-1.0.1.2
-process-1.0.1.5
+haskell2000-1.1.0.1
+haskell98-2.0.0.1
+hpc-0.5.1.1
+old-locale-1.0.0.4
+old-time-1.1.0.0
+pretty-1.1.1.0
+process-1.1.0.1
random-1.0.0.3
-template-haskell-2.5.0.0
-time-1.2.0.3
-unix-2.4.2.0
+template-haskell-2.7.0.0
+time-1.4
+unix-2.5.1.0
+Win32-2.2.2.0
Please sign in to comment.
Something went wrong with that request. Please try again.