Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

package versions list for 2012.4.0.0

  • Loading branch information...
commit acb1622bb31bf41b3438b172f082b25adbc668b8 1 parent 5413f6d
Mark Lentczner mzero authored
10 NOTES-2012.4.0.0
View
@@ -0,0 +1,10 @@
+
+[] revert to happy 1.18.9 if 1.18.10 doesn't build
+
+[] Versions issues:
+ [] cgi - haven't heard from maintainer, anything newer than version in
+ platform (3000.1.7.4) requires new packages
+ [] html - haven't heard from maintainer, but no new versions exist
+ [] GLUT & OpenGL - maintainer isn't sure that re-worked versions can
+ be prepared in time
+
11 RELEASE
View
@@ -41,7 +41,7 @@ T0
| xargs grep -i version: | grep -v -i cabal-version
[] update haskell-platform.cabal
- [] update src/gneric/tarball/packages/core.packages
+ [] update src/generic/tarball/packages/core.packages
* External libraries to latest stable version
* set up to build macos, and run
@@ -144,3 +144,12 @@ T0
* chrome 'download' redirects you to the 'thank you' + help page
* obtain scripts for Windows and Mac installers.
+
+ * a better format for Change List:
+ * clear indications for new / major update / minor update / same / dropped
+ * someway to include release notes from the packages themselves
+ * more automation for the generation of this information
+ (currently too much manual process)
+ * historical change lists should be in web site
+ (rather than just repo history)
+
90 download-website/changelog.markdown
View
@@ -4,7 +4,7 @@
Changelog for the Haskell Platform
-------------------
-2012.2.0.0
+2012.4.0.0
----------
**Contents of the Haskell Platform**
@@ -18,59 +18,62 @@ as [this Cabal file](https://github.com/haskell/haskell-platform/blob/master/has
***Core Libraries, Provided with GHC***
- * [array] <span class="versions">_0.3.0.2__0.4.0.0_</span>
- * [base] <span class="versions">_4.3.1.0__4.5.0.0_</span>
- * [bytestring] <span class="versions">_0.9.1.10__0.9.2.1_</span>
- * [Cabal] <span class="versions">_1.10.2.0__1.14.0_</span>
- * [containers] <span class="versions">_0.4.0.0__0.4.2.1_</span>
- * [deepseq] <span class="versions">_1.1.0.2__1.3.0.0_</span>
- * [directory] <span class="versions">_1.1.0.0__1.1.0.2_</span>
- * [extensible-exceptions] <span class="versions">_0.1.1.2__0.1.1.4_</span>
- * [filepath] <span class="versions">_1.2.0.0__1.3.0.0_</span>
- * [haskell2010] <span class="versions">_1.0.0.0__1.1.0.1_</span>
- * [haskell98] <span class="versions">_1.1.0.1__2.0.0.1_</span>
- * [hpc] <span class="versions">_0.5.0.6__0.5.1.1_</span>
- * [old-locale] <span class="versions">_1.0.0.2__1.0.0.4_</span>
- * [old-time] <span class="versions">_1.0.0.6__1.1.0.0_</span>
- * [pretty] <span class="versions">_1.0.1.2__1.1.1.0_</span>
- * [process] <span class="versions">_1.0.1.5__1.1.0.1_</span>
- * [template-haskell] <span class="versions">_2.5.0.0__2.7.0.0_</span>
- * [time] <span class="versions">_1.2.0.3__1.4_</span>
- * [unix] <span class="versions">_2.4.2.0__2.5.1.0_</span>
- * [Win32] <span class="versions">_2.2.0.1__2.2.2.0_</span>
+ * [array] <span class="versions">_(same)_ _0.4.0.0_</span>
+ * [base] <span class="versions">_4.5.0.0__4.5.1.0_</span>
+ * [bytestring] <span class="versions">_(same)_ _0.9.2.1_</span>
+ * [Cabal] <span class="versions">_(same)_ _1.14.0_</span>
+ * [containers] <span class="versions">_(same)_ _0.4.2.1_</span>
+ * [deepseq] <span class="versions">_(same)_ _1.3.0.0_</span>
+ * [directory] <span class="versions">_(same)_ _1.1.0.2_</span>
+ * [extensible-exceptions] <span class="versions">_(same)_ _0.1.1.4_</span>
+ * [filepath] <span class="versions">_(same)_ _1.3.0.0_</span>
+ * [haskell2010] <span class="versions">_(same)_ _1.1.0.1_</span>
+ * [haskell98] <span class="versions">_(same)_ _2.0.0.1_</span>
+ * [hpc] <span class="versions">_(same)_ _0.5.1.1_</span>
+ * [old-locale] <span class="versions">_(same)_ _1.0.0.4_</span>
+ * [old-time] <span class="versions">_(same)_ _1.1.0.0_</span>
+ * [pretty] <span class="versions">_(same)_ _1.1.1.0_</span>
+ * [process] <span class="versions">_(same)_ _1.1.0.1_</span>
+ * [template-haskell] <span class="versions">_(same)_ _2.7.0.0_</span>
+ * [time] <span class="versions">_(same)_ _1.4_</span>
+ * [unix] <span class="versions">_2.5.1.0__2.5.1.1_</span>
+ * [Win32] <span class="versions">_(same)_ _2.2.2.0_</span>
***Additional Platform Libraries***
+ * [async] <span class="versions">_(new)__2.0.1.3_</span>
* [cgi] <span class="versions">_(same)__3001.1.7.4_</span>
* [fgl] <span class="versions">_(same)__5.4.2.4_</span>
* [GLUT] <span class="versions">_(same)__2.1.2.1_</span>
- * [haskell-src] <span class="versions">_1.0.1.4__1.0.1.5_</span>
+ * [haskell-src] <span class="versions">_(same)_ _1.0.1.5_</span>
* [html] <span class="versions">_(same)__1.0.1.2_</span>
- * [HTTP] <span class="versions">_4000.1.2__4000.2.3_</span>
- * [HUnit] <span class="versions">_(same)_ _1.2.4.2_</span>
- * [mtl] <span class="versions">_2.0.1.0__2.1.1_</span>
- * [network] <span class="versions">_2.3.0.5_ _2.3.0.13_</span>
- * [OpenGL] <span class="versions">_2.2.3.0__2.2.3.1_</span>
- * [parallel] <span class="versions">_3.1.0.1__3.2.0.2_</span>
- * [parsec] <span class="versions">_3.1.1__3.1.2_</span>
- * [QuickCheck] <span class="versions">_2.4.1.1__2.4.2_</span>
- * [random] <span class="versions">_1.0.0.3__1.0.1.1_</span>
+ * [HTTP] <span class="versions">_4000.2.3__4000.2.5_</span>
+ * [HUnit] <span class="versions">_1.2.4.2__1.2.5.1_</span>
+ * [mtl] <span class="versions">_2.1.1_ _2.1.2_</span>
+ * [network] <span class="versions">_2.3.0.13__2.4.0.1_</span>
+ * [OpenGL] <span class="versions">_(same)_ _2.2.3.1_</span>
+ * [parallel] <span class="versions">_3.2.0.2__3.2.0.3_</span>
+ * [parsec] <span class="versions">_3.1.2__3.1.3_</span>
+ * [QuickCheck] <span class="versions">_2.4.2_ _2.5.1.1_</span>
+ * [random] <span class="versions">_(same)_ _1.0.1.1_</span>
* [regex-base] <span class="versions">_(same)__0.93.2_</span>
* [regex-compat] <span class="versions">_(same)__0.95.1_</span>
- * [regex-posix] <span class="versions">_(same)__0.95.1_</span>
- * [stm] <span class="versions">_2.2.0.1__2.3_</span>
- * [syb] <span class="versions">_0.3.3__0.3.6.1_</span>
- * [text] <span class="versions">_0.11.1.5__0.11.2.0_</span>
- * [transformers] <span class="versions">_0.2.2.0__0.3.0.0_</span>
- * [xhtml] <span class="versions">_3000.2.0.4__3000.2.1_</span>
- * [zlib] <span class="versions">_0.5.3.1__0.5.3.3_</span>
+ * [regex-posix] <span class="versions">_0.95.1__0.95.2_</span>
+ * [split] <span class="versions">_(new)__0.2.1.1_</span>
+ * [stm] <span class="versions">_2.3__2.4_</span>
+ * [syb] <span class="versions">_0.3.6.1__0.3.7_</span>
+ * [text] <span class="versions">_0.11.2.0__0.11.2.3_</span>
+ * [transformers] <span class="versions">_(same)__0.3.0.0_</span>
+ * [vector] <span class="versions">_(new)__0.10_</span>
+ * [xhtml] <span class="versions">_(same)__3000.2.1_</span>
+ * [zlib] <span class="versions">_0.5.3.3__0.5.4.0_</span>
***Programs and Tools***
- * [cabal-install] <span class="versions">_0.10.2__0.14.0_</span>
- * [alex] <span class="versions">_2.3.5__3.0.1_</span>
- * [happy] <span class="versions">_1.18.6__1.18.9_</span>
- * [haddock] <span class="versions">_2.9.2_ _2.10.0_</span>
+ * [cabal-install] <span class="versions">_(same)__0.14.0_</span>
+ * [alex] <span class="versions">_3.0.1__3.0.2_</span>
+ * [happy] <span class="versions">_1.18.9__1.18.10_</span>
+ * [haddock] <span class="versions">_2.10.0__2.11.0_</span>
[ghc]: http://haskell.org/ghc
@@ -94,6 +97,7 @@ as [this Cabal file](https://github.com/haskell/haskell-platform/blob/master/has
[time]: http://hackage.haskell.org/package/time
[unix]: http://hackage.haskell.org/package/unix
[Win32]: http://hackage.haskell.org/package/Win32
+[async]: http://hackage.haskell.org/package/async
[cgi]: http://hackage.haskell.org/package/cgi
[fgl]: http://hackage.haskell.org/package/fgl
[GLUT]: http://hackage.haskell.org/package/GLUT
@@ -111,10 +115,12 @@ as [this Cabal file](https://github.com/haskell/haskell-platform/blob/master/has
[regex-base]: http://hackage.haskell.org/package/regex-base
[regex-compat]: http://hackage.haskell.org/package/regex-compat
[regex-posix]: http://hackage.haskell.org/package/regex-posix
+[split]: http://hackage.haskell.org/package/split
[stm]: http://hackage.haskell.org/package/stm
[syb]: http://hackage.haskell.org/package/syb
[text]: http://hackage.haskell.org/package/text
[transformers]: http://hackage.haskell.org/package/transformers
+[vector]: http://hackage.haskell.org/package/vector
[xhtml]: http://hackage.haskell.org/package/xhtml
[zlib]: http://hackage.haskell.org/package/zlib
49 haskell-platform.cabal
View
@@ -1,5 +1,5 @@
name: haskell-platform
-version: 2012.2.0.0
+version: 2012.4.0.0
homepage: http://haskell.org/platform
license: BSD3
license-file: LICENSE
@@ -15,7 +15,7 @@ description:
.
This version specifies the following additional developer tools be
installed, for a system to be in full compliance:
- .
+ .
* cabal-install
* alex
* happy
@@ -23,16 +23,16 @@ description:
cabal-version: >= 1.8
build-type: Custom
-tested-with: GHC ==7.4.1
+tested-with: GHC ==7.4.2
library
build-depends:
- -- ghc ==7.4.1,
-
+ -- ghc ==7.4.2,
+
-- Core libraries: provided by every ghc installation
-- We don't include "non-API" packages here.
-- array ==0.4.0.0,
- -- base ==4.5.0.0,
+ -- base ==4.5.1.0,
-- bytestring ==0.9.2.1,
-- Cabal ==1.14.0,
-- containers ==0.4.2.1,
@@ -49,41 +49,44 @@ library
-- process ==1.1.0.1,
-- template-haskell ==2.7.0.0,
-- time ==1.4,
- -- unix ==2.5.1.0,
+ -- unix ==2.5.1.1,
-- Win32 ==2.2.2.0,
-- Libraries in addition to what GHC provides:
-- Note: newer versions of cgi need monad-catchio.
+ async ==2.0.1.3,
cgi ==3001.1.7.4,
fgl ==5.4.2.4,
GLUT ==2.1.2.1,
haskell-src ==1.0.1.5,
html ==1.0.1.2,
- HTTP ==4000.2.3,
- HUnit ==1.2.4.2,
- mtl ==2.1.1,
- network ==2.3.0.13,
+ HTTP ==4000.2.5,
+ HUnit ==1.2.5.1,
+ mtl ==2.1.2,
+ network ==2.4.0.1,
OpenGL ==2.2.3.1,
- parallel ==3.2.0.2,
- parsec ==3.1.2,
- QuickCheck ==2.4.2,
+ parallel ==3.2.0.3,
+ parsec ==3.1.3,
+ QuickCheck ==2.5.1.1,
random ==1.0.1.1,
regex-base ==0.93.2,
regex-compat ==0.95.1,
- regex-posix ==0.95.1,
- stm ==2.3,
- syb ==0.3.6.1,
- text ==0.11.2.0,
+ regex-posix ==0.95.2,
+ split ==0.2.1.1,
+ stm ==2.4,
+ syb ==0.3.7,
+ text ==0.11.2.3,
transformers ==0.3.0.0,
+ vector ==0.10,
xhtml ==3000.2.1,
- zlib ==0.5.3.3
+ zlib ==0.5.4.0
-- Depending on programs does not work, they are not registered
-- We list them to help distro packaging.
build-tools:
cabal-install ==0.14.0,
- alex ==3.0.1,
- happy ==1.18.9
- -- hscolour ==1.19
- -- haddock ==2.10.0 -- need to use the one shipped with ghc
+ alex ==3.0.2,
+ happy ==1.18.10
+ -- hscolour ==1.19 -- ???
+ -- haddock ==2.11.0 -- need to use the one shipped with ghc
4 src/generic/tarball/packages/core.packages
View
@@ -1,5 +1,5 @@
array-0.4.0.0
-base-4.5.0.0
+base-4.5.1.0
bytestring-0.9.2.1
Cabal-1.14.0
containers-0.4.2.1
@@ -17,4 +17,4 @@ pretty-1.1.1.0
process-1.1.0.1
template-haskell-2.7.0.0
time-1.4
-unix-2.5.1.0
+unix-2.5.1.1
Please sign in to comment.
Something went wrong with that request. Please try again.