Method #warden_cookies doesn't set cookies in the response #20

Closed
dlt opened this Issue Apr 25, 2011 · 8 comments

Projects

None yet

6 participants

@dlt
dlt commented Apr 25, 2011

The warden_cookies method stores the arguments passed to it in a hash, but doesn't set them in the response.

@doolin
Contributor
doolin commented Jun 5, 2011

I think is why I'm getting RSpec failure on lines 224 and 261 in spec/warden/proxy_spec.rb

@voxik
voxik commented Jul 26, 2011

@doolin: The test suite fails with rack 1.3 while it works fine with rack 1.2. I reported it as #26

@doolin
Contributor
doolin commented Jul 26, 2011

Cool, I'll be keeping an eye on it.

On Tue, Jul 26, 2011 at 8:10 AM, voxik
reply@reply.github.com
wrote:

@doolin: The test suite fails with rack 1.3 while it works fine with rack 1.2. I reported it as #26

Reply to this email directly or view it on GitHub:
#20 (comment)

http://dool.in

@punkrats

Hi there, do we have news on this topic?

I asked Daniel if he intends to keep that #warden_cookies method, since I could not find any tests for it and it obviously does not work. Are there any tests? Am I missing something here?

Unfortunately Daniel did not answer yet...

@josevalim
Collaborator

I am deprecating warden_cookies. :)

@punkrats
punkrats commented May 8, 2012

Very well. Fight the confusion. :)

@JonRowe
Contributor
JonRowe commented Feb 27, 2013

So has warden_cookies been deprecated and/or removed? Is this issue still necessary?

@josevalim
Collaborator

Yes, it has been deprecated. :)

@josevalim josevalim closed this Mar 2, 2013
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment