Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

admin arena white page issue #23

Closed
PowerChaos opened this issue Feb 17, 2017 · 5 comments

Comments

Projects
None yet
2 participants
@PowerChaos
Copy link

commented Feb 17, 2017

hi,
i got a fresh install of hoosk 1.5 but after install the admin arena only displays a white page
on same config i installed version 1.4 and then the admin arena works perfect

also few suggestions
installer still works with mysql instead mysqli/pdo
so it trows out errors xD

Greets From PowerChaos

@havok89

This comment has been minimized.

Copy link
Owner

commented Mar 6, 2017

The install script has now been updated to mysqli. I am unsure on the issue with with the white page, are you running it on a local server?

@PowerChaos

This comment has been minimized.

Copy link
Author

commented Mar 7, 2017

no, i run it on cpanel ( version 62 , centos 7 )
i tried it on differend compiled ways of apache ( because a other script dit not work eather, buildercms )
i used apache prefork as dso (then the other script works ...execution permissions ) and apache event with fastcgiD ( daemon ) but then the ohter script dit not work
anyway
version 1.5 dit ,not work on both settings , when version 1.4 does work on both versions

my guess is that it has to do with the new ajax session check , as after login ( session set ) it shows only the white page and nothing more ( refuse to execute any kind of html output ? )

it doesnt shows a error log and it doesnt shows any error code , so i guess it need to be the fresh added ajax code for the session

or in worste case ( a other error i found ) is that the RSS feed does NOT work ( error 500 )
probaly because it trows a 500 return error that the script stops working and prevent to show anything as the script can not execute ( that new added RSS feed at the home of the admin arena )

The error 500 is probably trown where the script try to curl to get the markup of the xml file, but i would think that it would provide then any logs of the execution error

i founded the rss bug when i was looking manual into the files
887f2fa

$this->data['recenltyUpdated'] = $this->Hoosk_model->getUpdatedPages();
$this->load->library('rssparser');
$this->rssparser->set_feed_url('http://hoosk.org/feed/rss');
$this->rssparser->set_cache_life(30);
$this->data['hooskFeed'] = $this->rssparser->getFeed(3);

here is the feed response ( xml reader plugin for chrome xD )

A PHP Error was encountered

Severity: Notice

Message: Undefined index: author

Filename: feed/rss.php

Line Number: 26

Backtrace:

File: /home/theloxie/public_html/hooskorg/theme/hoosk2015/feed/rss.php
Line: 26
Function: _error_handler

File: /home/theloxie/public_html/hooskorg/hoosk/hoosk0/core/MY_Loader.php
Line: 128 ......

Greets From PowerChaos

@havok89

This comment has been minimized.

Copy link
Owner

commented Mar 7, 2017

It does sound like it could be to do with the RSS then,

If you open your index.php file at line 64 you can change "production" to "development" and it should output any errors it encounters.

https://github.com/havok89/Hoosk/blob/master/index.php

@PowerChaos

This comment has been minimized.

Copy link
Author

commented Mar 7, 2017

Thank you
i also dit some more tests and at current moment i can reproduce the error
it counts for all versions
seems it was just unlucky to hit the 500 page at that time

if you change the feed url to hoosker.org then it perfectly reproduce the error
Message: file_get_contents(): php_network_getaddresses: getaddrinfo failed: Name or service not known

can you put a fix in the script so the controllers doesnt break on warning and continue , specialy with remote url files ?

also htacces need a small change ( for fastcgiD )
RewriteRule .* index.php?/$0 [PT,L]
it need to have that ? after index.php or rewrite does not work xD

Greets From PowerChaos

@havok89

This comment has been minimized.

Copy link
Owner

commented Mar 8, 2017

Have added a fix for the error message in relation to the RSS feed and added a RSS flag in the index.php, can set it to false to disable the RSS feed display.
https://github.com/havok89/Hoosk/releases/tag/v1.5.6

Just noticed your point about the htaccess, will add into the next update

@havok89 havok89 closed this Mar 27, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.