Permalink
Browse files

release

  • Loading branch information...
1 parent 84c9d15 commit 0ba9f973c9ec682699d1e20c392fe0e2b655bea1 @hayeah committed Dec 19, 2010
Showing with 66 additions and 6 deletions.
  1. +3 −4 Gemfile
  2. +2 −2 Rakefile
  3. +61 −0 daisydiff.gemspec
View
7 Gemfile
@@ -6,8 +6,7 @@ source "http://rubygems.org"
# Add dependencies to develop your gem here.
# Include everything needed to run rake, tests, features, etc.
group :development do
- gem "rspec", "~> 2.1.0"
- gem "bundler", "~> 1.0.0"
- gem "jeweler", "~> 1.5.1"
- gem "rcov", ">= 0"
+ gem "rspec"
+ gem "bundler"
+ gem "jeweler"
end
View
4 Rakefile
@@ -15,8 +15,8 @@ Jeweler::Tasks.new do |gem|
gem.name = "daisydiff"
gem.homepage = "http://github.com/hayeah/daisydiff"
gem.license = "MIT"
- gem.summary = %Q{TODO: one-line summary of your gem}
- gem.description = %Q{TODO: longer description of your gem}
+ gem.summary = %Q{JRuby HTML Diffing}
+ gem.description = %Q{Wrapper for DaisyDiff}
gem.email = "hayeah@gmail.com"
gem.authors = ["Howard Yeh"]
# Include your dependencies below. Runtime dependencies are required when using your gem,
View
61 daisydiff.gemspec
@@ -0,0 +1,61 @@
+# Generated by jeweler
+# DO NOT EDIT THIS FILE DIRECTLY
+# Instead, edit Jeweler::Tasks in Rakefile, and run 'rake gemspec'
+# -*- encoding: utf-8 -*-
+
+Gem::Specification.new do |s|
+ s.name = %q{daisydiff}
+ s.version = "0.1.0"
+
+ s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
+ s.authors = ["Howard Yeh"]
+ s.date = %q{2010-12-18}
+ s.description = %q{Wrapper for DaisyDiff}
+ s.email = %q{hayeah@gmail.com}
+ s.extra_rdoc_files = [
+ "LICENSE.txt",
+ "README.rdoc"
+ ]
+ s.files = [
+ ".document",
+ ".rspec",
+ "Gemfile",
+ "LICENSE.txt",
+ "README.rdoc",
+ "Rakefile",
+ "VERSION",
+ "lib/daisydiff.rb",
+ "lib/daisydiff/daisydiff.jar",
+ "spec/daisydiff_spec.rb",
+ "spec/spec_helper.rb"
+ ]
+ s.homepage = %q{http://github.com/hayeah/daisydiff}
+ s.licenses = ["MIT"]
+ s.require_paths = ["lib"]
+ s.rubygems_version = %q{1.3.6}
+ s.summary = %q{JRuby HTML Diffing}
+ s.test_files = [
+ "spec/daisydiff_spec.rb",
+ "spec/spec_helper.rb"
+ ]
+
+ if s.respond_to? :specification_version then
+ current_version = Gem::Specification::CURRENT_SPECIFICATION_VERSION
+ s.specification_version = 3
+
+ if Gem::Version.new(Gem::RubyGemsVersion) >= Gem::Version.new('1.2.0') then
+ s.add_development_dependency(%q<rspec>, [">= 0"])
+ s.add_development_dependency(%q<bundler>, [">= 0"])
+ s.add_development_dependency(%q<jeweler>, [">= 0"])
+ else
+ s.add_dependency(%q<rspec>, [">= 0"])
+ s.add_dependency(%q<bundler>, [">= 0"])
+ s.add_dependency(%q<jeweler>, [">= 0"])
+ end
+ else
+ s.add_dependency(%q<rspec>, [">= 0"])
+ s.add_dependency(%q<bundler>, [">= 0"])
+ s.add_dependency(%q<jeweler>, [">= 0"])
+ end
+end
+

0 comments on commit 0ba9f97

Please sign in to comment.