Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Hazelcast 3.10 xsd on website does not correspond to the xsd in the jar #13011

Closed
MichelSchudel opened this Issue May 1, 2018 · 9 comments

Comments

Projects
None yet
5 participants
@MichelSchudel
Copy link

MichelSchudel commented May 1, 2018

The Hazelcast 3.10 xsd located at https://hazelcast.com/schema/config/hazelcast-config-3.10.xsd does not correspond to the hazelcast-config-3.10.xsd in the hazelcast jar. We encountered this while configuring a merge policy for a multiMap while we had a schema declaration in the config xml that pointed to the external xsd on the website.

@mmedenjak mmedenjak added this to the 3.11 milestone May 8, 2018

@mmedenjak

This comment has been minimized.

Copy link
Contributor

mmedenjak commented May 8, 2018

@MichelSchudel thanks for the report!
@mesutcelik do you know how this XSD is published? Do we need to republish?

@mesutcelik

This comment has been minimized.

Copy link
Contributor

mesutcelik commented May 8, 2018

It is normally published when we do release of hazelcast patch or minor version. There is no nightly upload unfortunately.

@MichelSchudel Is this any issue in your IDE? Normally hazelcast uses XSD within the jar file so no need to check what is available on the web.

@mmedenjak

This comment has been minimized.

Copy link
Contributor

mmedenjak commented May 18, 2018

@MichelSchudel any updates on this issue?

@MichelSchudel

This comment has been minimized.

Copy link
Author

MichelSchudel commented May 18, 2018

@mesutcelik

This comment has been minimized.

Copy link
Contributor

mesutcelik commented Feb 25, 2019

@Holmistr @hasancelik
I remember each .com website refresh was overriding XSDs. Did we fix that problem?

@Holmistr

This comment has been minimized.

Copy link
Collaborator

Holmistr commented Feb 27, 2019

I believe it should be fixed now. I'm kind of busy, would you mind checking this?

@mesutcelik

This comment has been minimized.

Copy link
Contributor

mesutcelik commented Feb 28, 2019

@Holmistr ,
I checked and they are the same. If you think after your fix , that will not happen again then you can close the issue.

@Holmistr

This comment has been minimized.

Copy link
Collaborator

Holmistr commented Feb 28, 2019

Yep, closing this issue.

@Holmistr Holmistr closed this Feb 28, 2019

@mmedenjak mmedenjak modified the milestones: 3.13, 3.12 Feb 28, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.
You signed in with another tab or window. Reload to refresh your session. You signed out in another tab or window. Reload to refresh your session.