Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

hazelcast-wm >= 3.3 OSGI Manifest spring package imports should not be required #6072

Closed
fwassmer opened this issue Aug 27, 2015 · 3 comments

Comments

Projects
None yet
4 participants
@fwassmer
Copy link
Contributor

commented Aug 27, 2015

Starting with hazelcast-wm 3.3.0 spring packages are imported and required in the Manifest.mf,
so hazlecast-wm can only be started when spring is also installed:

org.springframework.context;version="[3.1,4)",
org.springframework.security.core.session;version="[3.1,4)",
org.springframework.security.web.session;version="[3.1,4)",
org.springframework.web.context;version="[3.1,4)",
org.springframework.web.context.support;versio n="[3.1,4)"

Those dependencies should be set to be optional with resolution:=optional
in the pom ( <Import-Package>... ):
e.g.: org.springframework.context;version="[3.1,4)";resolution:=optional

@bilalyasar

This comment has been minimized.

Copy link
Collaborator

commented Aug 27, 2015

@fwassmer yes your findings seems logical. If you want, you can create PR about this issue..

@fwassmer

This comment has been minimized.

Copy link
Contributor Author

commented Aug 27, 2015

PR created: #6073

@serkan-ozal

This comment has been minimized.

Copy link
Contributor

commented Sep 1, 2015

closed via #6073

@serkan-ozal serkan-ozal closed this Sep 1, 2015

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.