Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

OSGi bundle install failure in 3.6.1 #7772

Closed
skellogg opened this issue Mar 16, 2016 · 4 comments

Comments

Projects
None yet
2 participants
@skellogg
Copy link

commented Mar 16, 2016

in Karaf, bundle:install...
Error executing command: Can't install feature cosc-base/0.0.0:
Could not start bundle mvn:com.hazelcast/hazelcast/3.6.1 in feature(s) cosc-base-0.0.1-SNAPSHOT, cosc-api-0.0.1-SNAPSHOT: Unresolved constraint in bundle com.hazelcast [114]: Unable to resolve 114.0: missing requirement [114.0] osgi.wiring.package; (osgi.wiring.package=com.hazelcast.client.impl.protocol.codec)

@serkan-ozal serkan-ozal added this to the 3.6.2 milestone Mar 17, 2016

@serkan-ozal serkan-ozal self-assigned this Mar 17, 2016

@serkan-ozal

This comment has been minimized.

Copy link
Contributor

commented Mar 21, 2016

This should have been fixed by this PR #7630
So this issue will be fixed at 3.6.2+ and 3.7 releases

@skellogg

This comment has been minimized.

Copy link
Author

commented Mar 21, 2016

I failed to mention, it worked fine in 3.6.0, but failed in 3.6.1

@skellogg skellogg closed this Mar 21, 2016

@skellogg

This comment has been minimized.

Copy link
Author

commented Mar 21, 2016

didn't mean to close, sorry.

@skellogg skellogg reopened this Mar 21, 2016

@serkan-ozal

This comment has been minimized.

Copy link
Contributor

commented Mar 21, 2016

Hi @skellogg

Yes, there is no issue at 3.6.0. Because the issue has been occured since 3.6.1 after hazelcast-client-protocol depedency has been added.

With 3.6.2 it will be OK since there will be no import package statement for com.hazelcast.client.impl.protocol.codec with this PR #7630.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.